Commit 8809b21d authored by Alberto Garcia's avatar Alberto Garcia
Browse files

Remove some obsolete build dependencies

parent 5f974a57
webkit2gtk (2.30.4-2) UNRELEASED; urgency=medium
* Remove some obsolete build dependencies (Closes: #979170):
+ gawk is not needed since WebKitGTK switched from autotools to CMake.
+ libgeoclue-2-dev and geoclue-2.0 are not required since WebKitGTK
2.25.1 (upstream bug 195994).
+ libupower-glib-dev is not required since WebKitGTK 2.19.92 (upstream
bug 181825).
+ libfile-copy-recursive-perl is not required since WebKitGTK 2.19.3
(upstream bug 180479).
+ mesa-common-dev used to provide GL/gl.h but this header is now in
libgl-dev.
+ libgles2-mesa-dev used to provide GLES3/gl3.h but this header is now
in libgles-dev.
+ libgl1-mesa-dev and libgles2-mesa-dev are now dummy packages.
+ libpango1.0-dev is not checked for any specific version at build
time so there's no need to list it.
-- Alberto Garcia <berto@igalia.com> Thu, 07 Jan 2021 14:23:52 +0100
webkit2gtk (2.30.4-1) unstable; urgency=high
* New upstream release.
......
......@@ -6,24 +6,20 @@ Uploaders: Gustavo Noronha Silva <kov@debian.org>,
Emilio Pozuelo Monfort <pochu@debian.org>,
Alberto Garcia <berto@igalia.com>
X-Ubuntu-Use-Langpack: no
Build-Depends: gawk,
bubblewrap (>= 0.3.1) [!alpha !ia64 !m68k !riscv64 !sh4 !sparc64],
Build-Depends: bubblewrap (>= 0.3.1) [!alpha !ia64 !m68k !riscv64 !sh4 !sparc64],
xdg-dbus-proxy [!alpha !ia64 !m68k !riscv64 !sh4 !sparc64],
libseccomp-dev [!alpha !ia64 !m68k !riscv64 !sh4 !sparc64],
cmake (>= 3.3),
debhelper (>= 11.2~),
jdupes,
libfile-copy-recursive-perl,
libglib2.0-dev (>= 2.36.0),
libgtk-3-dev (>= 3.10.0),
libpango1.0-dev (>= 1.30.0),
libharfbuzz-dev (>= 0.9.18),
libcairo2-dev (>= 1.10.2),
libfontconfig1-dev (>= 2.8),
libfreetype6-dev,
libicu-dev,
libgcrypt20-dev (>= 1.7.0),
libgeoclue-2-dev,
libhyphen-dev,
libnotify-dev,
libxslt1-dev (>= 1.1.7),
......@@ -32,7 +28,6 @@ Build-Depends: gawk,
libsqlite3-dev (>= 3.0),
libsystemd-dev,
libgudev-1.0-dev [linux-any],
libupower-glib-dev,
libwoff-dev (>= 1.0.2),
libwpebackend-fdo-1.0-dev,
gperf,
......@@ -48,15 +43,13 @@ Build-Depends: gawk,
libgstreamer1.0-dev (>= 1.13.1),
libgstreamer-plugins-base1.0-dev (>= 1.13.1),
libenchant-2-dev,
geoclue-2.0,
libsecret-1-dev,
gobject-introspection (>= 1.32.0),
libgirepository1.0-dev (>= 0.9.12-4),
mesa-common-dev,
ninja-build,
libegl1-mesa-dev,
libgl1-mesa-dev,
libgles2-mesa-dev
libgl-dev,
libgles-dev
Build-Depends-Indep: gtk-doc-tools,
libglib2.0-doc,
libgtk-3-doc,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment