Commit 8e3f6f3a authored by Alberto Garcia's avatar Alberto Garcia
Browse files

New upstream version 2.30.0

parent 09d062a2
......@@ -14,7 +14,7 @@
<div class="titlepage">
<div>
<div><table class="navigation" id="top" width="100%" cellpadding="2" cellspacing="0"><tr><th valign="middle"><p class="title">JavaScriptCore GLib Reference Manual</p></th></tr></table></div>
<div><p class="releaseinfo">for JavaScriptCore 2.29.92</p></div>
<div><p class="releaseinfo">for JavaScriptCore 2.30.0</p></div>
</div>
<hr>
</div>
......
......@@ -169,13 +169,13 @@ have included when compiling your code.</p>
<hr>
<div class="refsect2">
<a name="JSC-MINOR-VERSION:CAPS"></a><h3>JSC_MINOR_VERSION</h3>
<pre class="programlisting">#define JSC_MINOR_VERSION (29)
<pre class="programlisting">#define JSC_MINOR_VERSION (30)
</pre>
</div>
<hr>
<div class="refsect2">
<a name="JSC-MICRO-VERSION:CAPS"></a><h3>JSC_MICRO_VERSION</h3>
<pre class="programlisting">#define JSC_MICRO_VERSION (92)
<pre class="programlisting">#define JSC_MICRO_VERSION (0)
</pre>
</div>
</div>
......
......@@ -14,7 +14,7 @@
<div class="titlepage">
<div>
<div><table class="navigation" id="top" width="100%" cellpadding="2" cellspacing="0"><tr><th valign="middle"><p class="title">WebKitGTK Reference Manual</p></th></tr></table></div>
<div><p class="releaseinfo">for WebKitGTK 2.29.92</p></div>
<div><p class="releaseinfo">for WebKitGTK 2.30.0</p></div>
</div>
<hr>
</div>
......
......@@ -204,7 +204,7 @@ against at application run time.</p>
<hr>
<div class="refsect2">
<a name="WEBKIT-MINOR-VERSION:CAPS"></a><h3>WEBKIT_MINOR_VERSION</h3>
<pre class="programlisting">#define WEBKIT_MINOR_VERSION (29)
<pre class="programlisting">#define WEBKIT_MINOR_VERSION (30)
</pre>
<p>Like <a class="link" href="webkit2gtk-4.0-WebKitVersion.html#webkit-get-minor-version" title="webkit_get_minor_version ()"><code class="function">webkit_get_minor_version()</code></a>, but from the headers used at
application compile time, rather than from the library linked
......@@ -213,7 +213,7 @@ against at application run time.</p>
<hr>
<div class="refsect2">
<a name="WEBKIT-MICRO-VERSION:CAPS"></a><h3>WEBKIT_MICRO_VERSION</h3>
<pre class="programlisting">#define WEBKIT_MICRO_VERSION (92)
<pre class="programlisting">#define WEBKIT_MICRO_VERSION (0)
</pre>
<p>Like <a class="link" href="webkit2gtk-4.0-WebKitVersion.html#webkit-get-micro-version" title="webkit_get_micro_version ()"><code class="function">webkit_get_micro_version()</code></a>, but from the headers used at
application compile time, rather than from the library linked
......
......@@ -14,7 +14,7 @@
<div class="titlepage">
<div>
<div><table class="navigation" id="top" width="100%" cellpadding="2" cellspacing="0"><tr><th valign="middle"><p class="title">WebKitDOMGTK+ Reference Manual</p></th></tr></table></div>
<div><p class="releaseinfo">for WebKitDOMGTK+ 2.29.92</p></div>
<div><p class="releaseinfo">for WebKitDOMGTK+ 2.30.0</p></div>
</div>
<hr>
</div>
......
================
WebKitGTK 2.30.0
================
What's new in WebKitGTK 2.30.0?
- Fix NTLM authentication.
- Don't try to use SHM on wayland with older wpebackend-fdo.
- Fix the build due to seccomp.h heasder not found.
=================
WebKitGTK 2.29.92
=================
......
......@@ -132,6 +132,7 @@ SoupNetworkSession::SoupNetworkSession(PAL::SessionID sessionID)
SOUP_SESSION_TIMEOUT, 0,
SOUP_SESSION_IDLE_TIMEOUT, 0,
SOUP_SESSION_ADD_FEATURE_BY_TYPE, SOUP_TYPE_CONTENT_SNIFFER,
SOUP_SESSION_ADD_FEATURE_BY_TYPE, SOUP_TYPE_AUTH_NTLM,
#if SOUP_CHECK_VERSION(2, 67, 90)
SOUP_SESSION_ADD_FEATURE_BY_TYPE, SOUP_TYPE_WEBSOCKET_EXTENSION_MANAGER,
#endif
......
......@@ -447,6 +447,7 @@ list(APPEND WebKit_SYSTEM_INCLUDE_DIRECTORIES
${GSTREAMER_INCLUDE_DIRS}
${GSTREAMER_PBUTILS_INCLUDE_DIRS}
${GTK_INCLUDE_DIRS}
${LIBSECCOMP_INCLUDE_DIRS}
${LIBSOUP_INCLUDE_DIRS}
)
......
......@@ -136,10 +136,12 @@ static bool tryInitializeSHM()
#if WPE_FDO_CHECK_VERSION(1, 7, 0)
if (!wpe_fdo_initialize_shm())
return false;
#endif
s_waylandImpl = WaylandImpl::SHM;
return true;
#else
return false;
#endif
}
#endif // USE(WPE_RENDERER)
......
================
WebKitGTK 2.30.0
================
What's new in WebKitGTK 2.30.0?
- Fix NTLM authentication.
- Don't try to use SHM on wayland with older wpebackend-fdo.
- Fix the build due to seccomp.h heasder not found.
=================
WebKitGTK 2.29.92
=================
......
......@@ -4,7 +4,7 @@ include(VersioningUtils)
WEBKIT_OPTION_BEGIN()
WEBKIT_OPTION_DEFINE(USE_GTK4 "Whether to enable usage of GTK4 instead of GTK3." PUBLIC OFF)
SET_PROJECT_VERSION(2 29 92)
SET_PROJECT_VERSION(2 30 0)
if (USE_GTK4)
set(WEBKITGTK_API_VERSION 5.0)
......@@ -13,10 +13,10 @@ if (USE_GTK4)
else ()
set(WEBKITGTK_API_VERSION 4.0)
set(GTK_MINIMUM_VERSION 3.22.0)
CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(WEBKIT 86 3 49)
CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(WEBKIT 86 4 49)
endif ()
CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(JAVASCRIPTCORE 35 7 17)
CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(JAVASCRIPTCORE 35 8 17)
# These are shared variables, but we special case their definition so that we can use the
# CMAKE_INSTALL_* variables that are populated by the GNUInstallDirs macro.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment