Commit ec225f5f authored by David Boddie's avatar David Boddie

Merge branch 'qemu-flag-context' into 'master'

Update text to reflect that most new OSes will have the qemu fix

Closes #29

See merge request Librem5/developer.puri.sm!78
parents a861ecd1 d7d75f69
Pipeline #2139 passed with stage
in 30 seconds
......@@ -25,7 +25,7 @@ First, checkout the `official documentation for GNOME Builder <https://builder.r
Setting up QEMU on Debian based systems
***************************************
Since Builder relies on statically linked qemu binaries, you will either need to run an OS that already does this for you (like Fedora) or fix up your Debian workstation to enforce static linking before starting Builder. Manually fixing Debian qemu binaries (setting flags: F) is required until a patched version of qemu is distributed by PureOS/Debian. Without statically linked qemu binaries, you will not be able to build an installable armhf or aarch64 flatpak from Builder.
Since Builder relies on statically linked qemu binaries, you will either need to run an OS that already does this for you (like Fedora, Debian Buster, or PureOS) or fix up your Debian stable workstation to enforce static linking before starting Builder. Manually fixing Debian qemu binaries (setting flags: F) is required until a patched version of qemu is distributed by your OS. Without statically linked qemu binaries, you will not be able to build an installable armhf or aarch64 flatpak from Builder.
To perform these operations, you will need to be the root user (sudo is not good enough).
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment