control.in 6.14 KB
Newer Older
1 2 3 4
Source: gnome-software
Section: gnome
Priority: optional
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Jeremy Bicha's avatar
Jeremy Bicha committed
5
Uploaders: @GNOME_TEAM@
mak's avatar
mak committed
6 7
Build-Depends: appstream,
               appstream-util,
8
               debhelper-compat (= 12),
9 10
               docbook-xsl,
               gnome-pkg-tools (>= 0.10),
mak's avatar
mak committed
11
               gsettings-desktop-schemas-dev (>= 3.18),
12
               gtk-doc-tools,
13
               libappstream-glib-dev (>= 0.7.14),
Jeremy Bicha's avatar
Jeremy Bicha committed
14
               libflatpak-dev (>= 0.99.3) [amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64],
15
               libfwupd-dev (>= 1.0.3) [linux-any],
16
               libglib2.0-dev (>= 2.56.0),
17
               libgnome-desktop-3-dev (>= 3.18.0),
18
               libgoa-1.0-dev,
19
               libgspell-1-dev,
20
               libgtk-3-dev (>= 3.22.4),
21
               libgudev-1.0-dev [linux-any],
22
               libjson-glib-dev (>= 1.2.0),
23
               libpackagekit-glib2-dev (>= 1.1.11),
24
               libpolkit-gobject-1-dev,
25
               libsnapd-glib-dev (>= 1.45) [amd64 arm64 armel armhf i386 ppc64el s390x],
26
               libsoup2.4-dev (>= 2.52.0),
27
               libxmlb-dev (>= 0.1.4),
28
               libxml2-utils,
29
               meson (>= 0.40),
30
               pkg-config,
31
               valgrind [amd64 arm64 armhf i386 mips mips64 mips64el mipsel powerpc ppc64 ppc64el s390x],
32
               xsltproc
33
Rules-Requires-Root: no
Jeremy Bicha's avatar
Jeremy Bicha committed
34
Standards-Version: 4.3.0
35 36
Vcs-Browser: https://salsa.debian.org/gnome-team/gnome-software
Vcs-Git: https://salsa.debian.org/gnome-team/gnome-software.git
37 38 39 40
Homepage: https://wiki.gnome.org/Apps/Software

Package: gnome-software
Architecture: any
mak's avatar
mak committed
41
Depends: appstream,
42
         apt-config-icons,
mak's avatar
mak committed
43
         gnome-software-common (= ${source:Version}),
mak's avatar
mak committed
44
         gsettings-desktop-schemas (>= 3.18),
45
         libgtk3-perl,
46
         packagekit (>= 1.1.11),
mak's avatar
mak committed
47
         software-properties-gtk,
48 49
         ${misc:Depends},
         ${shlibs:Depends}
50 51
Replaces: gnome-packagekit-session (<< 3.16.0-2~)
Breaks: gnome-packagekit-session (<< 3.16.0-2~)
Jeremy Bicha's avatar
Jeremy Bicha committed
52
Conflicts: sessioninstaller
53
Recommends: ${plugin:Recommends},
54
            fwupd [linux-any]
55
Suggests: apt-config-icons-hidpi,
Jeremy Bicha's avatar
Jeremy Bicha committed
56
          gnome-software-plugin-flatpak [amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64],
57
          ${plugin:Suggests}
58 59 60 61 62 63 64
Description: Software Center for GNOME
 Software lets you install and update applications and system extensions.
 .
 Software uses a plugin architecture to separate the frontend from the
 technologies that are used underneath. Currently, a PackageKit plugin provides
 data from a number of traditional packaging systems, such as rpm or apt. An
 appdata plugin provides additional metadata from locally installed data in the
Laurent Bigonville's avatar
Laurent Bigonville committed
65
 appdata format.
66 67 68

Package: gnome-software-common
Architecture: all
69
Multi-Arch: foreign
70 71 72 73 74 75 76 77
Depends: ${misc:Depends}
Description: Software Center for GNOME (common files)
 Software lets you install and update applications and system extensions.
 .
 Software uses a plugin architecture to separate the frontend from the
 technologies that are used underneath. Currently, a PackageKit plugin provides
 data from a number of traditional packaging systems, such as rpm or apt. An
 appdata plugin provides additional metadata from locally installed data in the
Laurent Bigonville's avatar
Laurent Bigonville committed
78
 appdata format.
79
 .
80
 This package contains the architecture-independent files.
81

82
Package: gnome-software-plugin-flatpak
83
Architecture: amd64 arm64 armel armhf i386 mips mips64el ppc64el s390x hppa powerpc powerpcspe ppc64
mak's avatar
mak committed
84 85
Depends: flatpak,
         gnome-software (= ${binary:Version}),
86 87 88 89 90 91 92 93 94 95 96 97
         ${misc:Depends},
         ${shlibs:Depends}
Description: Flatpak support for GNOME Software
 Software lets you install and update applications and system extensions.
 .
 Software uses a plugin architecture to separate the frontend from the
 technologies that are used underneath. Currently, a PackageKit plugin provides
 data from a number of traditional packaging systems, such as rpm or apt. An
 appdata plugin provides additional metadata from locally installed data in the
 appdata format.
 .
 This package contains the Flatpak plugin.
98

99
Package: gnome-software-plugin-snap
100
Architecture: amd64 arm64 armel armhf i386 ppc64el s390x
101
Depends: gnome-software (= ${binary:Version}),
102
         snapd [amd64 arm64 armel armhf i386 ppc64el],
103
         ${misc:Depends},
104
         ${shlibs:Depends}
105
Recommends: snapd [s390x]
106 107 108 109 110 111 112 113 114 115 116 117
Breaks: gnome-software (<< 3.22.3)
Replaces: gnome-software (<< 3.22.3)
Description: Snap support for GNOME Software
 Software lets you install and update applications and system extensions.
 .
 Software uses a plugin architecture to separate the frontend from the
 technologies that are used underneath. Currently, a PackageKit plugin provides
 data from a number of traditional packaging systems, such as rpm or apt. An
 appdata plugin provides additional metadata from locally installed data in the
 appdata format.
 .
 This package contains the Snap plugin.
118

119 120 121 122 123 124 125 126 127 128 129
Package: gnome-packagekit-session
Architecture: all
Section: oldlibs
Depends: gnome-software (>= ${source:Version}),
         ${misc:Depends}
Description: Transitional package (gnome-packagekit-session -> gnome-software)
 Transitional dummy package replacing gnome-packagekit-session with
 gnome-software.
 .
 The PackageKit session interface is no separate component anymore, but built
 into GNOME-Software.
130 131 132 133

Package: gnome-software-dev
Section: libdevel
Architecture: any
Jeremy Bicha's avatar
Jeremy Bicha committed
134
Multi-Arch: same
135
Depends: libappstream-glib-dev (>= 0.7.14),
136 137 138
         libglib2.0-dev (>= 2.56.0),
         libgtk-3-dev (>= 3.22.4),
         libsoup2.4-dev (>= 2.52.0),
139 140 141 142 143 144 145 146 147 148 149
         ${misc:Depends}
Suggests: gnome-software-doc
Description: Software Center for GNOME - development files
 Software lets you install and update applications and system extensions.
 .
 This package contains headers and other files required when compiling external
 plugins for use with Software.

Package: gnome-software-doc
Section: doc
Architecture: all
Jeremy Bicha's avatar
Jeremy Bicha committed
150
Multi-Arch: foreign
151 152 153 154 155 156
Depends: ${misc:Depends}
Description: Software Center for GNOME - documentation
 Software lets you install and update applications and system extensions.
 .
 This package contains documentation for use when developing plugins for
 Software.