Commit e52d2fa5 authored by Matthias Klumpp's avatar Matthias Klumpp
Browse files

Drop icon-download APT config snippet, depend on shared apt-config-icons instead

parent cc7777a3
...@@ -16,8 +16,8 @@ Build-Depends: appstream, ...@@ -16,8 +16,8 @@ Build-Depends: appstream,
libfwupd-dev (>= 1.0.3) [amd64 arm64 armhf i386], libfwupd-dev (>= 1.0.3) [amd64 arm64 armhf i386],
libglib2.0-dev (>= 2.46), libglib2.0-dev (>= 2.46),
libgnome-desktop-3-dev (>= 3.18.0), libgnome-desktop-3-dev (>= 3.18.0),
libgtk-3-dev (>= 3.22.4),
libgspell-1-dev, libgspell-1-dev,
libgtk-3-dev (>= 3.22.4),
libgudev-1.0-dev [linux-any], libgudev-1.0-dev [linux-any],
libjson-glib-dev (>= 1.2.0), libjson-glib-dev (>= 1.2.0),
liblimba-dev (>= 0.5.6) [linux-any], liblimba-dev (>= 0.5.6) [linux-any],
...@@ -41,6 +41,7 @@ Homepage: https://wiki.gnome.org/Apps/Software ...@@ -41,6 +41,7 @@ Homepage: https://wiki.gnome.org/Apps/Software
Package: gnome-software Package: gnome-software
Architecture: any Architecture: any
Depends: appstream, Depends: appstream,
apt-config-icons,
gnome-software-common (= ${source:Version}), gnome-software-common (= ${source:Version}),
gsettings-desktop-schemas (>= 3.18), gsettings-desktop-schemas (>= 3.18),
libgtk3-perl, libgtk3-perl,
...@@ -50,7 +51,8 @@ Depends: appstream, ...@@ -50,7 +51,8 @@ Depends: appstream,
${shlibs:Depends} ${shlibs:Depends}
Replaces: gnome-packagekit-session (<< 3.16.0-2~) Replaces: gnome-packagekit-session (<< 3.16.0-2~)
Breaks: gnome-packagekit-session (<< 3.16.0-2~) Breaks: gnome-packagekit-session (<< 3.16.0-2~)
Suggests: fwupd [amd64 arm64 armhf i386], Suggests: apt-config-icons-hidpi,
fwupd [amd64 arm64 armhf i386],
gnome-software-plugin-flatpak [linux-any], gnome-software-plugin-flatpak [linux-any],
gnome-software-plugin-limba [linux-any], gnome-software-plugin-limba [linux-any],
gnome-software-plugin-snap [linux-any] gnome-software-plugin-snap [linux-any]
...@@ -119,7 +121,7 @@ Architecture: amd64 arm64 armel armhf i386 ppc64 ppc64el s390x ...@@ -119,7 +121,7 @@ Architecture: amd64 arm64 armel armhf i386 ppc64 ppc64el s390x
Depends: gnome-software (= ${binary:Version}), Depends: gnome-software (= ${binary:Version}),
snapd [amd64 arm64 armel armhf i386 ppc64 ppc64el], snapd [amd64 arm64 armel armhf i386 ppc64 ppc64el],
${misc:Depends}, ${misc:Depends},
${shlibs:Depends}, ${shlibs:Depends}
Recommends: snapd [s390x] Recommends: snapd [s390x]
Breaks: gnome-software (<< 3.22.3) Breaks: gnome-software (<< 3.22.3)
Replaces: gnome-software (<< 3.22.3) Replaces: gnome-software (<< 3.22.3)
...@@ -150,9 +152,9 @@ Package: gnome-software-dev ...@@ -150,9 +152,9 @@ Package: gnome-software-dev
Section: libdevel Section: libdevel
Architecture: any Architecture: any
Multi-Arch: same Multi-Arch: same
Depends: libglib2.0-dev, Depends: libappstream-glib-dev,
libglib2.0-dev,
libgtk-3-dev, libgtk-3-dev,
libappstream-glib-dev,
libsoup2.4-dev, libsoup2.4-dev,
${misc:Depends} ${misc:Depends}
Suggests: gnome-software-doc Suggests: gnome-software-doc
......
## This file is provided by GNOME Software to enable the download of
## small-size 64x64px icons for use in the software catalog.
##
## The icons are required for GNOME Software to function correctly.
## Applications without an icon will not be displayed at all.
Acquire::IndexTargets {
deb::DEP-11-icons {
DefaultEnabled "true";
};
};
debian/extra/60gnome-software /etc/apt/apt.conf.d/
etc/xdg/autostart/ etc/xdg/autostart/
usr/bin/gnome-software usr/bin/gnome-software
usr/bin/gnome-software-editor usr/bin/gnome-software-editor
......
rm_conffile /etc/apt/apt.conf.d/60gnome-software 3.28.0-1
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment