Commit e49c11eb authored by Adrien Plazas's avatar Adrien Plazas

meson: Add dependency on libhandy 0.0.10

parent 6ce4c5d6
......@@ -103,6 +103,7 @@ gio_unix = dependency('gio-unix-2.0', version : '>= 2.56.0')
gmodule = dependency('gmodule-2.0')
goa = dependency('goa-1.0')
gtk = dependency('gtk+-3.0', version : '>= 3.22.4')
libhandy = dependency('libhandy-0.0', version: '>= 0.0.10')
json_glib = dependency('json-glib-1.0', version : '>= 1.2.0')
libm = cc.find_library('m', required: false)
libsoup = dependency('libsoup-2.4', version : '>= 2.52.0')
......
......@@ -13,6 +13,8 @@
#include <gio/gio.h>
#include <gio/gdesktopappinfo.h>
#include <gtk/gtk.h>
#define HANDY_USE_UNSTABLE_API
#include <handy.h>
#include <locale.h>
#include "gs-application.h"
......@@ -32,6 +34,8 @@ main (int argc, char **argv)
bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
textdomain (GETTEXT_PACKAGE);
hdy_init (&argc, &argv);
/* redirect logs */
application = gs_application_new ();
appinfo = g_desktop_app_info_new ("org.gnome.Software.desktop");
......
......@@ -76,6 +76,7 @@ gnome_software_dependencies = [
gmodule,
goa,
gtk,
libhandy,
json_glib,
libm,
libsoup
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment