Commit a31c6a43 authored by Adrien Plazas's avatar Adrien Plazas

Document changes and release 3.30.0+541+git958b1c8b-1pureos0

parent 958b1c8b
Pipeline #60624 passed with stages
in 6 minutes and 29 seconds
gnome-usage (3.30.0+541+git958b1c8-1pureos0) amber-phone; urgency=medium
[ Christopher Davis ]
* Retire app menu
[ Piotr Drąg ]
* Update POTFILES.in
* Update Polish translation
* Update POTFILES.in and POTFILES.skip
* Update Polish translation
* Update POTFILES.in and POTFILES.skip
[ Daniel Mustieles ]
* Updated Spanish translation
* Updated Spanish translation
[ Kukuh Syafaat ]
* Update Indonesian translation
* Update Indonesian translation
[ Rafael Fontenelle ]
* Update Brazilian Portuguese translation
* Update Brazilian Portuguese translation
[ yodatak ]
* Add Flatpak build on the CI
* Simplify the build
* Update .gitlab-ci.yml
* Update .gitlab-ci.yml
* Simplyfy + Set the expiration to 7 days + remove args
[ Petr Štětka ]
* graphs: Remove rg and egg library
* graphs: Add custom vapi for libdazzle
* graphs: Replace rg library with Dazzle library
* CI: Add libdazzle dependency
* header-bar: Add filter processes button
* app-item: Add AppItem class for simplify SystemMonitor
* system-monitor: Simplify SystemMonitor
* quit-process-dialog: Simplify QuitProcessDialog according to backend
* process-row: Simplify ProcessRow according to backend
* process-list-box: Simplify ProcessListBox according to backend
* Remove unused files
* system-monitor: Add support for grouping system processes to backend
* gschema.xml: Add "system" to default unkillable processes
* process-list-box: Update list-box when system-monitor notices
* Add action on activate group-system-processes radio button
* cpu-sub-view: Update showing list-box acording to backend state
* memory-sub-view: Update showing list-box acording to backend state
* primary-menu: Merge performance filter button and primary menu into one
* primary-menu: remove unused variable, it fix build warning
* DBus method FindUserById throws GLib.Error instead of GLib.IOError
* Remove unused code: graph-block and graph-block-row
* css: remove unused css code
[ Abderrahim Kitouni ]
* flatpak: build libdazzle
[ Marek Cernocky ]
* Updated Czech translation
[ Anders Jonsson ]
* Update Swedish translation
[ Felipe Borges ]
* speedometer: Don't add GtkLabel twice to Speedometer
* icons: Update to new icon
* Release 3.32.0
[ Jiri Grönroos ]
* Update Finnish translation
[ Balázs Úr ]
* Update Hungarian translation
[ Fran Dieguez ]
* Update Galician translation
[ Emin Tufan Çetin ]
* Update Turkish translation
[ Ask Hjorth Larsen ]
* add da to LINGUAS
* Updated Danish translation
[ Nathan Follens ]
* Update Dutch translation
[ Gianvito Cavasoli ]
* Update Italian translation
* Update Italian translation
[ Fabio Tomat ]
* Update Friulian translation
[ Марко Костић ]
* Update Serbian translation
[ Asier Sarasua Garmendia ]
* Add Basque translation
[ Charles Monzat ]
* Update French translation
[ Rico Tzschichholz ]
* Constructors of abstract classes should not be public
[ Adrien Plazas ]
* debian: Add dependency on libdazzle-1.0 >= 3.30.0
* Add libhandy 0.0.10 dependency
* librem5: window: Drop the hardcoded minimum size
* performance-view: Replace the GtkPaned by a HdyLeaflet
* storage-view: Replace the GtkPaned by a HdyLeaflet
* librem5: storage-view: Hide the action bar
* performance-view: Use a HdyColumn
* cpu-sub-view: Don't horizontally center
* memory-sub-view: Don't horizontally center
* cpu-sub-view: Don't hardcode the width
* process-row: Don't hardcode the width
* performance-view: Make the search bar adaptive
* performance-view: Set a minimum width to the content box
* Add the speedometer-symbolic icon
* application: Load icon resources
* Add icons to the pages
* Replace GtkHeaderBar by HdyHeaderBar
* Replace GtkStackSwitcher by HdyViewSwitcher
* Add a HdyViewSwitcherBar
* header-bar: Hide the storage selection button
* Add a HdySqueezer to move the view switcher to the bottom of the window
* header-bar: Ensure buttons are shown only in the right mode
* heaer-bar: Put the storage rescan button in a revealer
* debian: Add the libhandy-0.0 >= 0.0.10 dependency
* data: List compatible form-factors
[ Guido Günther ]
* debian: Use gtherm
* Add initial thermal view
* Add gitlab-ci
* Build-dep on tracker-sparql
* Recommend gthd
-- Adrien Plazas <kekun@pureos> Fri, 06 Nov 2020 15:46:36 +0100
gnome-usage (3.30.0-2) unstable; urgency=medium
* Build-Depend on debhelper-compat 12 and drop debian/compat
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment