Verified Commit d5addf29 authored by Sebastian Krzyszkowiak's avatar Sebastian Krzyszkowiak
Browse files

profile.d: Check whether Qt has Wayland backend available before attempting to use it

This fixes Qt apps when `qtwayland5` package is not installed by letting them use X11 instead.
parent bc6c646f
Pipeline #65232 passed with stages
in 7 minutes and 22 seconds
# Help some windowing systems along until they use wayland by default # Help some windowing systems along until they use wayland by default
export QT_QPA_PLATFORM if [ -f "/usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/qt5/plugins/wayland-shell-integration/libxdg-shell.so" ]; then
QT_QPA_PLATFORM=wayland export QT_QPA_PLATFORM
QT_QPA_PLATFORM=wayland
fi
export MOZ_ENABLE_WAYLAND export MOZ_ENABLE_WAYLAND
MOZ_ENABLE_WAYLAND=1 MOZ_ENABLE_WAYLAND=1
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment