setup-pureos-pkg-repo: Don't use obsolete API for protecting branches

The correct way (nowadays) to protect a branch is by using the
protected_branches endpoint
(see https://docs.gitlab.com/ee/api/protected_branches.html)

Fixes #4
4 jobs for fix-protected-branches-setup-pkg-repo in 3 minutes and 43 seconds (queued for 1 second)