Commit 6a0706f2 authored by Guido Gunther's avatar Guido Gunther Committed by Guido Gunther

build: Make libhandy dep explicit

Signed-off-by: Guido Gunther's avatarGuido Günther <guido.gunther@puri.sm>
parent 2b6a96a2
Pipeline #49903 passed with stages
in 11 minutes and 52 seconds
......@@ -113,6 +113,11 @@ libgvc = subproject('gvc',
'alsa=false'
])
libgvc_dep = libgvc.get_variable('libgvc_dep')
libhandy_dep = dependency('libhandy-0.0',
version: '>=0.0.12',
fallback: ['libhandy', 'libhandy_dep'],
default_options: ['introspection=disabled']
)
libnm_dep = dependency('libnm', version: '>= 1.14')
libpolkit_agent_dep = dependency('polkit-agent-1', version: '>= 0.105')
network_agent_dep = dependency('libsecret-1')
......
......@@ -140,11 +140,7 @@ phosh_deps = [
dependency('gtk+-3.0', version: '>=3.22'),
dependency('gtk+-wayland-3.0', version: '>=3.22'),
dependency('wayland-client', version: '>=1.14'),
dependency('libhandy-0.0',
version: '>=0.0.12',
fallback: ['libhandy', 'libhandy_dep'],
default_options: ['introspection=disabled']
),
libhandy_dep,
dependency('upower-glib', version: '>=0.99.1'),
libgvc_dep,
libnm_dep,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment