Commit 232b555a authored by Adrien Plazas's avatar Adrien Plazas
Browse files

Merge branch 'wip-byzantium' into 'pureos/byzantium'

byzantium: Rebase on 3.38 and make adaptive

See merge request !16
parents 6d92dcac 03837abb
Pipeline #67146 passed with stages
in 7 minutes and 7 seconds
gnome-software (3.38.1-1) unstable; urgency=medium
pureos-store (3.38.1-1+pureos1) unstable; urgency=medium
[ Mohammed Sadiq ]
* debian: Update gbp.conf
* debian: Add librem5-ci
[ Adrien Plazas ]
* debian: Disable snap
* debian: Disable fwupd support
* debian: Drop the dependency on software-properties-gtk
* debian: Drop the custom verified icon patch
* Patches
* debian: Add the libhandy-1 dependency
* debian: Rebrand as PureOS Store
* debian: Conflicts with gnome-software et al.
[ Guido Günther ]
* d/control: Add Provides:
-- Adrien Plazas <adrien.plazas@puri.sm> Fri, 30 Apr 2021 08:35:12 +0200
pureos-store (3.38.1-1) unstable; urgency=medium
* Team upload
* New upstream release
......@@ -9,13 +30,13 @@ gnome-software (3.38.1-1) unstable; urgency=medium
-- Simon McVittie <smcv@debian.org> Thu, 18 Feb 2021 15:08:20 +0000
gnome-software (3.38.0-3) unstable; urgency=medium
pureos-store (3.38.0-3) unstable; urgency=medium
* Add an upstream patch to fix offline updates (Closes: #972506)
-- Laurent Bigonville <bigon@debian.org> Wed, 23 Dec 2020 09:33:29 +0100
gnome-software (3.38.0-2) unstable; urgency=medium
pureos-store (3.38.0-2) unstable; urgency=medium
* Team upload
......@@ -32,7 +53,7 @@ gnome-software (3.38.0-2) unstable; urgency=medium
-- Simon McVittie <smcv@debian.org> Mon, 05 Oct 2020 18:42:42 +0100
gnome-software (3.38.0-1) unstable; urgency=medium
pureos-store (3.38.0-1) unstable; urgency=medium
* New upstream release
* Bump debhelper-compat to 13
......@@ -40,20 +61,20 @@ gnome-software (3.38.0-1) unstable; urgency=medium
-- Gunnar Hjalmarsson <gunnarhj@ubuntu.com> Mon, 05 Oct 2020 12:25:03 +0200
gnome-software (3.36.1-2) unstable; urgency=medium
pureos-store (3.36.1-2) unstable; urgency=medium
* Enable malcontent on supported architectures
-- Laurent Bigonville <bigon@debian.org> Sun, 05 Jul 2020 18:24:31 +0200
gnome-software (3.36.1-1) unstable; urgency=medium
pureos-store (3.36.1-1) unstable; urgency=medium
* New upstream release
- Drop patches that were cherry-picked from upstream
-- Laurent Bigonville <bigon@debian.org> Sun, 07 Jun 2020 11:25:25 +0200
gnome-software (3.36.0-3) unstable; urgency=medium
pureos-store (3.36.0-3) unstable; urgency=medium
* Fix missing icons in the store, patch from upstream.
Thanks to Matthias Klumpp <matthias@tenstral.net>
......@@ -62,7 +83,7 @@ gnome-software (3.36.0-3) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Mon, 27 Apr 2020 15:13:57 +0200
gnome-software (3.36.0-2) unstable; urgency=medium
pureos-store (3.36.0-2) unstable; urgency=medium
* Add fix-appstream-featured-data.patch
- This restores a regression fix that was accidentally reverted
......@@ -72,13 +93,13 @@ gnome-software (3.36.0-2) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Thu, 02 Apr 2020 18:16:58 +0200
gnome-software (3.36.0-1) unstable; urgency=medium
pureos-store (3.36.0-1) unstable; urgency=medium
* New upstream release
-- Laurent Bigonville <bigon@debian.org> Wed, 11 Mar 2020 14:35:17 +0100
gnome-software (3.35.91-1) experimental; urgency=medium
pureos-store (3.35.91-1) experimental; urgency=medium
* New upstream release
- Drop d/p/0001-gs-appstream-Fix-loading-of-icons-from-AppStream-YAM.patch
......@@ -94,7 +115,7 @@ gnome-software (3.35.91-1) experimental; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Sun, 01 Mar 2020 13:33:18 +0100
gnome-software (3.34.2-2) unstable; urgency=medium
pureos-store (3.34.2-2) unstable; urgency=medium
* Stop overriding libexecdir and move the daemons to /usr/libexec now that
this is allowed in the debian policy
......@@ -108,7 +129,7 @@ gnome-software (3.34.2-2) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Sun, 01 Mar 2020 11:39:19 +0100
gnome-software (3.34.2-1) unstable; urgency=medium
pureos-store (3.34.2-1) unstable; urgency=medium
* debian/rules: Use filter instead of findstring to detect the architecture,
this will avoid matching partial names like ppc64 and ppc64el
......@@ -120,7 +141,7 @@ gnome-software (3.34.2-1) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Tue, 17 Dec 2019 18:17:52 +0100
gnome-software (3.34.0-1) unstable; urgency=medium
pureos-store (3.34.0-1) unstable; urgency=medium
[ Jeremy Bicha ]
* New upstream release (3.31.90)
......@@ -147,7 +168,7 @@ gnome-software (3.34.0-1) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Wed, 04 Dec 2019 13:55:11 +0100
gnome-software (3.30.6-5) unstable; urgency=medium
pureos-store (3.30.6-5) unstable; urgency=medium
* Cherry-pick 8 Snap patches via Ubuntu
- Support switching channels, add verified developer support, use
......@@ -157,21 +178,21 @@ gnome-software (3.30.6-5) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Sun, 24 Feb 2019 21:09:02 -0500
gnome-software (3.30.6-4) unstable; urgency=medium
pureos-store (3.30.6-4) unstable; urgency=medium
* Re-enable Flatpak on mipsel
* Don't enable snap on ppc64 since snapd never built there
-- Jeremy Bicha <jbicha@debian.org> Thu, 10 Jan 2019 17:25:24 -0500
gnome-software (3.30.6-3) unstable; urgency=medium
pureos-store (3.30.6-3) unstable; urgency=medium
* Don't try building Flatpak support on architectures where Flatpak
isn't built
-- Jeremy Bicha <jbicha@debian.org> Sun, 06 Jan 2019 01:44:44 -0500
gnome-software (3.30.6-2) unstable; urgency=medium
pureos-store (3.30.6-2) unstable; urgency=medium
* Recommend instead of Suggest fwupd (Closes: #916036)
* Enable fwupd on all Linux architectures
......@@ -183,7 +204,7 @@ gnome-software (3.30.6-2) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Sat, 05 Jan 2019 17:26:30 -0500
gnome-software (3.30.6-1) unstable; urgency=medium
pureos-store (3.30.6-1) unstable; urgency=medium
* New upstream release
* Bump required libappstream-glib-dev to >= 0.7.14
......@@ -196,7 +217,7 @@ gnome-software (3.30.6-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Fri, 21 Dec 2018 10:16:34 -0500
gnome-software (3.30.5-1) unstable; urgency=medium
pureos-store (3.30.5-1) unstable; urgency=medium
[ Jeremy Bicha ]
* New upstream release
......@@ -210,7 +231,7 @@ gnome-software (3.30.5-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Fri, 16 Nov 2018 16:48:13 -0500
gnome-software (3.30.1-1) unstable; urgency=medium
pureos-store (3.30.1-1) unstable; urgency=medium
* New upstream release
* debian/control.in: Bump build-dependencies
......@@ -219,13 +240,13 @@ gnome-software (3.30.1-1) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Fri, 05 Oct 2018 11:57:57 +0200
gnome-software (3.28.2-1) unstable; urgency=medium
pureos-store (3.28.2-1) unstable; urgency=medium
* New upstream release
-- Jeremy Bicha <jbicha@debian.org> Mon, 14 May 2018 22:01:33 -0400
gnome-software (3.28.1-1) unstable; urgency=medium
pureos-store (3.28.1-1) unstable; urgency=medium
* New upstream release
* Bump Standards-Version to 4.1.4
......@@ -233,13 +254,13 @@ gnome-software (3.28.1-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Tue, 10 Apr 2018 19:45:35 -0400
gnome-software (3.28.0-1) unstable; urgency=medium
pureos-store (3.28.0-1) unstable; urgency=medium
* New upstream release
-- Jeremy Bicha <jbicha@debian.org> Fri, 16 Mar 2018 17:22:24 -0400
gnome-software (3.27.92-1) unstable; urgency=medium
pureos-store (3.27.92-1) unstable; urgency=medium
* New upstream release candidate
* Update gsettings schema names for new release ("sources" renamed to
......@@ -250,7 +271,7 @@ gnome-software (3.27.92-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Sat, 10 Mar 2018 21:13:52 -0500
gnome-software (3.27.90-1) experimental; urgency=medium
pureos-store (3.27.90-1) experimental; urgency=medium
* New upstream development release
* Bump dependencies for new version:
......@@ -261,7 +282,7 @@ gnome-software (3.27.90-1) experimental; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Sun, 18 Feb 2018 16:27:18 -0500
gnome-software (3.26.5-1) unstable; urgency=medium
pureos-store (3.26.5-1) unstable; urgency=medium
* New upstream release
* Update Vcs fields for migration to https://salsa.debian.org/
......@@ -269,7 +290,7 @@ gnome-software (3.26.5-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Sat, 20 Jan 2018 07:48:06 -0500
gnome-software (3.26.3-4) unstable; urgency=medium
pureos-store (3.26.3-4) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
......@@ -279,19 +300,19 @@ gnome-software (3.26.3-4) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Sat, 16 Dec 2017 13:24:18 -0500
gnome-software (3.26.3-3) unstable; urgency=medium
pureos-store (3.26.3-3) unstable; urgency=medium
* Fix arch:all build
-- Jeremy Bicha <jbicha@debian.org> Fri, 24 Nov 2017 19:57:28 -0500
gnome-software (3.26.3-2) unstable; urgency=medium
pureos-store (3.26.3-2) unstable; urgency=medium
* Only build snap plugin on architectures where snapd is built.
-- Jeremy Bicha <jbicha@debian.org> Fri, 24 Nov 2017 16:31:19 -0500
gnome-software (3.26.3-1) unstable; urgency=medium
pureos-store (3.26.3-1) unstable; urgency=medium
* New upstream release
* Use appstream-util appdata-to-news to install NEWS
......@@ -299,7 +320,7 @@ gnome-software (3.26.3-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Tue, 21 Nov 2017 19:19:28 -0500
gnome-software (3.26.2-1) unstable; urgency=medium
pureos-store (3.26.2-1) unstable; urgency=medium
* New upstream release
* debian/control.in:
......@@ -308,7 +329,7 @@ gnome-software (3.26.2-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Fri, 10 Nov 2017 09:30:30 -0500
gnome-software (3.26.1-2) unstable; urgency=medium
pureos-store (3.26.1-2) unstable; urgency=medium
* Cherry-pick upstream fixes to make gnome-software build against fwupd 1.0.
(Closes: #879006)
......@@ -316,21 +337,21 @@ gnome-software (3.26.1-2) unstable; urgency=medium
-- Michael Biebl <biebl@debian.org> Sat, 21 Oct 2017 05:36:14 +0200
gnome-software (3.26.1-1) unstable; urgency=medium
pureos-store (3.26.1-1) unstable; urgency=medium
* New upstream release
* Bump Standards-Version to 4.1.1
-- Jeremy Bicha <jbicha@debian.org> Thu, 05 Oct 2017 22:02:21 -0400
gnome-software (3.26.0-2) unstable; urgency=medium
pureos-store (3.26.0-2) unstable; urgency=medium
* Only build with valgrind on architectures where valgrind is available
* Bump Standards-Version to 4.1.0
-- Jeremy Bicha <jbicha@debian.org> Fri, 15 Sep 2017 08:20:01 -0400
gnome-software (3.26.0-1) unstable; urgency=medium
pureos-store (3.26.0-1) unstable; urgency=medium
[ Jeremy Bicha ]
* Release to unstable
......@@ -344,7 +365,7 @@ gnome-software (3.26.0-1) unstable; urgency=medium
-- Jeremy Bicha <jbicha@debian.org> Thu, 14 Sep 2017 20:30:08 -0400
gnome-software (3.25.91-1) experimental; urgency=medium
pureos-store (3.25.91-1) experimental; urgency=medium
* debian/compat: Bump to 10, mainly to get --parallel by default.
* New upstream release 3.25.91 (LP: #1706715)
......@@ -353,7 +374,7 @@ gnome-software (3.25.91-1) experimental; urgency=medium
-- Iain Lane <laney@debian.org> Thu, 24 Aug 2017 16:33:38 +0100
gnome-software (3.25.4-1) experimental; urgency=medium
pureos-store (3.25.4-1) experimental; urgency=medium
* New upstream release 3.25.4
* debian/rules: Switch to debhelper's meson buildsystem instead of calling
......@@ -363,7 +384,7 @@ gnome-software (3.25.4-1) experimental; urgency=medium
-- Iain Lane <laney@debian.org> Tue, 25 Jul 2017 13:02:15 +0100
gnome-software (3.25.3-1) experimental; urgency=medium
pureos-store (3.25.3-1) experimental; urgency=medium
* New upstream release 3.25.3
* debian/control{,.in}: Bump libappstrem-glib-dev and libfwupd-dev versions
......@@ -373,7 +394,7 @@ gnome-software (3.25.3-1) experimental; urgency=medium
-- Iain Lane <laney@debian.org> Fri, 23 Jun 2017 17:44:59 +0100
gnome-software (3.25.1-1) experimental; urgency=medium
pureos-store (3.25.1-1) experimental; urgency=medium
[ Jeremy Bicha ]
* debian/control.in:
......@@ -396,7 +417,7 @@ gnome-software (3.25.1-1) experimental; urgency=medium
-- Iain Lane <laney@debian.org> Fri, 05 May 2017 17:31:43 +0100
gnome-software (3.22.5-1) unstable; urgency=medium
pureos-store (3.22.5-1) unstable; urgency=medium
* New upstream bugfix release: 3.22.5
* Add support for the PureOS Debian derivative
......@@ -407,7 +428,7 @@ gnome-software (3.22.5-1) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Sun, 22 Jan 2017 19:06:34 +0100
gnome-software (3.22.4-1) unstable; urgency=medium
pureos-store (3.22.4-1) unstable; urgency=medium
[ Jeremy Bicha ]
* debian/gnome-software.gsettings-override.in, debian/rules:
......@@ -425,7 +446,7 @@ gnome-software (3.22.4-1) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Mon, 12 Dec 2016 11:46:39 +0100
gnome-software (3.22.1-1) unstable; urgency=medium
pureos-store (3.22.1-1) unstable; urgency=medium
[ Helmut Grohne ]
* Fix FTCBFS: Deconfuse build vs. host. (Closes: #839878)
......@@ -443,7 +464,7 @@ gnome-software (3.22.1-1) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Sat, 22 Oct 2016 16:32:42 +0200
gnome-software (3.22.0-1) unstable; urgency=medium
pureos-store (3.22.0-1) unstable; urgency=medium
[ Jeremy Bicha ]
* New upstream release
......@@ -490,14 +511,14 @@ gnome-software (3.22.0-1) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Thu, 22 Sep 2016 20:48:42 +0200
gnome-software (3.20.2-2) unstable; urgency=medium
pureos-store (3.20.2-2) unstable; urgency=medium
* debian/rules: Do not use -X parameter for dh_install, some files were not
installed as expected.
-- Laurent Bigonville <bigon@debian.org> Tue, 26 Apr 2016 14:26:44 +0200
gnome-software (3.20.2-1) unstable; urgency=medium
pureos-store (3.20.2-1) unstable; urgency=medium
[ Matthias Klumpp ]
* New upstream release: 3.20.2
......@@ -522,7 +543,7 @@ gnome-software (3.20.2-1) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Mon, 25 Apr 2016 18:12:18 +0200
gnome-software (3.18.3-3) unstable; urgency=medium
pureos-store (3.18.3-3) unstable; urgency=medium
* Add 01_fwupd-dont-crash.patch: Don't crash when the fwupd daemon
is removed.
......@@ -531,7 +552,7 @@ gnome-software (3.18.3-3) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Fri, 15 Jan 2016 15:14:42 +0100
gnome-software (3.18.3-2) unstable; urgency=medium
pureos-store (3.18.3-2) unstable; urgency=medium
* Enable fwupd support
- This allows updating flashed firmware from GNOME-Software
......@@ -541,14 +562,14 @@ gnome-software (3.18.3-2) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Mon, 14 Dec 2015 16:02:42 +0100
gnome-software (3.18.3-1) unstable; urgency=medium
pureos-store (3.18.3-1) unstable; urgency=medium
* New upstream bugfix release
- Closes: #803418
-- Matthias Klumpp <mak@debian.org> Thu, 05 Nov 2015 20:04:16 +0100
gnome-software (3.18.2-2) unstable; urgency=medium
pureos-store (3.18.2-2) unstable; urgency=medium
* Add missing Breaks/Replaces against gnome-packagekit-session
- Closes: #802458
......@@ -558,7 +579,7 @@ gnome-software (3.18.2-2) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Wed, 21 Oct 2015 20:26:34 +0200
gnome-software (3.18.2-1) unstable; urgency=medium
pureos-store (3.18.2-1) unstable; urgency=medium
[ Michael Biebl ]
* Use https:// for Vcs-Browser
......@@ -578,20 +599,20 @@ gnome-software (3.18.2-1) unstable; urgency=medium
-- Matthias Klumpp <mak@debian.org> Wed, 14 Oct 2015 19:54:10 +0200
gnome-software (3.16.5-2) unstable; urgency=medium
pureos-store (3.16.5-2) unstable; urgency=medium
* Add transitional package for the PK session interface
* Do not ship with Fedora-specific plugins
-- Matthias Klumpp <mak@debian.org> Sat, 08 Aug 2015 18:18:44 +0200
gnome-software (3.16.5-1) unstable; urgency=medium
pureos-store (3.16.5-1) unstable; urgency=medium
* New upstream release.
-- Michael Biebl <biebl@debian.org> Thu, 06 Aug 2015 16:27:58 +0200
gnome-software (3.16.4-1) unstable; urgency=medium
pureos-store (3.16.4-1) unstable; urgency=medium
* New upstream release.
* Update Build-Depends as per configure.ac:
......@@ -606,7 +627,7 @@ gnome-software (3.16.4-1) unstable; urgency=medium
-- Michael Biebl <biebl@debian.org> Wed, 22 Jul 2015 00:03:04 +0200
gnome-software (3.14.2-1) unstable; urgency=medium
pureos-store (3.14.2-1) unstable; urgency=medium
* New upstream release
* debian/control.in: Bump both appstream-glib build and runtime dependencies
......@@ -615,13 +636,13 @@ gnome-software (3.14.2-1) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Tue, 18 Nov 2014 23:08:05 +0100
gnome-software (3.14.1-2) unstable; urgency=medium
pureos-store (3.14.1-2) unstable; urgency=medium
* debian/rules, debian/gnome-software.install: Install appdata file
-- Laurent Bigonville <bigon@debian.org> Sat, 25 Oct 2014 02:36:59 +0200
gnome-software (3.14.1-1) unstable; urgency=medium
pureos-store (3.14.1-1) unstable; urgency=medium
* New upstream release
- debian/control.in: Bump gtk+-3.0 build-dependency to 3.14.1
......@@ -629,7 +650,7 @@ gnome-software (3.14.1-1) unstable; urgency=medium
-- Laurent Bigonville <bigon@debian.org> Sat, 18 Oct 2014 09:12:33 +0200
gnome-software (3.14.0-1) unstable; urgency=low
pureos-store (3.14.0-1) unstable; urgency=low
* Initial release (Closes: #722316)
......
......@@ -2,7 +2,7 @@
#
# Modifications should be made to debian/control.in instead.
# This file is regenerated automatically in the clean target.
Source: gnome-software
Source: pureos-store
Section: gnome
Priority: optional
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
......@@ -23,12 +23,12 @@ Build-Depends: appstream,
libgspell-1-dev,
libgtk-3-dev (>= 3.22.4),
libgudev-1.0-dev [linux-any],
libhandy-1-dev (>= 1.0.0),
libjson-glib-dev (>= 1.2.0),
libostree-dev [linux-any],
libmalcontent-0-dev [amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64],
libpackagekit-glib2-dev (>= 1.1.11),
libpolkit-gobject-1-dev,
libsnapd-glib-dev (>= 1.54) [amd64 arm64 armel armhf i386 ppc64el s390x],
libsoup2.4-dev (>= 2.52.0),
libxml2-utils,
libxmlb-dev (>= 0.1.7),
......@@ -45,44 +45,46 @@ Build-Depends-Indep: appstream-glib-doc <!nodoc>,
libsoup2.4-doc <!nodoc>
Rules-Requires-Root: no
Standards-Version: 4.5.0
Vcs-Browser: https://salsa.debian.org/gnome-team/gnome-software
Vcs-Git: https://salsa.debian.org/gnome-team/gnome-software.git
Homepage: https://wiki.gnome.org/Apps/Software
X-Ubuntu-Use-Langpack: yes
Vcs-Browser: https://source.puri.sm/Librem5/pureos-store
Vcs-Git: https://source.puri.sm/Librem5/pureos-store.git
Homepage: https://source.puri.sm/Librem5/pureos-store
Package: gnome-software
Package: pureos-store
Architecture: any
Depends: appstream,
apt-config-icons,
gnome-software-common (= ${source:Version}),
pureos-store-common (= ${source:Version}),
gsettings-desktop-schemas (>= 3.18),
libgtk3-perl,
packagekit (>= 1.1.11),
software-properties-gtk,
${misc:Depends},
${shlibs:Depends}
Conflicts: sessioninstaller
Conflicts: gnome-software,
sessioninstaller
Provides: gnome-software
Recommends: fwupd [linux-any], ${plugin:Recommends}
Suggests: apt-config-icons-hidpi,
gnome-software-plugin-flatpak [amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64],
pureos-store-plugin-flatpak [amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64],
${plugin:Suggests}
Description: Software Center for GNOME
Software lets you install and update applications and system extensions.
Description: Software Center for PureOS
PureOS Store lets you install and update applications and system extensions.
.
Software uses a plugin architecture to separate the frontend from the
PureOS Store uses a plugin architecture to separate the frontend from the
technologies that are used underneath. Currently, a PackageKit plugin provides
data from a number of traditional packaging systems, such as rpm or apt. An
appdata plugin provides additional metadata from locally installed data in the
appdata format.
Package: gnome-software-common
Package: pureos-store-common
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
Description: Software Center for GNOME (common files)
Software lets you install and update applications and system extensions.
Conflicts: gnome-software-common
Provides: gnome-software-common
Description: Software Center for PureOS (common files)
PureOS Store lets you install and update applications and system extensions.
.
Software uses a plugin architecture to separate the frontend from the
PureOS Store uses a plugin architecture to separate the frontend from the
technologies that are used underneath. Currently, a PackageKit plugin provides
data from a number of traditional packaging systems, such as rpm or apt. An
appdata plugin provides additional metadata from locally installed data in the
......@@ -90,16 +92,18 @@ Description: Software Center for GNOME (common files)
.
This package contains the architecture-independent files.
Package: gnome-software-plugin-flatpak
Package: pureos-store-plugin-flatpak
Architecture: amd64 arm64 armel armhf hppa i386 mips mips64el powerpc powerpcspe ppc64 ppc64el s390x
Depends: flatpak,
gnome-software (= ${binary:Version}),
pureos-store (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Description: Flatpak support for GNOME Software
Software lets you install and update applications and system extensions.
Conflicts: gnome-software-plugin-flatpak
Provides: gnome-software-plugin-flatpak
Description: Flatpak support for PureOS Store
PureOS Store lets you install and update applications and system extensions.
.
Software uses a plugin architecture to separate the frontend from the
PureOS Store uses a plugin architecture to separate the frontend from the
technologies that are used underneath. Currently, a PackageKit plugin provides
data from a number of traditional packaging systems, such as rpm or apt. An
appdata plugin provides additional metadata from locally installed data in the
......@@ -107,27 +111,7 @@ Description: Flatpak support for GNOME Software
.
This package contains the Flatpak plugin.
Package: gnome-software-plugin-snap
Architecture: amd64 arm64 armel armhf i386 ppc64el s390x
Depends: gnome-software (= ${binary:Version}),
snapd [amd64 arm64 armel armhf i386 ppc64el],
${misc:Depends},
${shlibs:Depends}
Recommends: snapd [s390x]
Breaks: gnome-software (<< 3.22.3)
Replaces: gnome-software (<< 3.22.3)
Description: Snap support for GNOME Software
Software lets you install and update applications and system extensions.
.
Software uses a plugin architecture to separate the frontend from the
technologies that are used underneath. Currently, a PackageKit plugin provides
data from a number of traditional packaging systems, such as rpm or apt. An
appdata plugin provides additional metadata from locally installed data in the
appdata format.
.
This package contains the Snap plugin.
Package: gnome-software-dev
Package: pureos-store-dev
Section: libdevel
Architecture: any
Multi-Arch: same
......@@ -136,21 +120,23 @@ Depends: libappstream-glib-dev (>= 0.7.14),
libgtk-3-dev (>= 3.22.4),
libsoup2.4-dev (>= 2.52.0),
${misc:Depends}
Suggests: gnome-software-doc
Description: Software Center for GNOME - development files
Software lets you install and update applications and system extensions.
Conflicts: gnome-software-dev
Suggests: pureos-store-doc
Description: Software Center for PureOS - development files
PureOS Store lets you install and update applications and system extensions.
.
This package contains headers and other files required when compiling external
plugins for use with Software.
plugins for use with PureOS Store.
Package: gnome-software-doc
Package: pureos-store-doc
Section: doc
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
Conflicts: gnome-software-doc
Bui