Commit 3e0131e2 authored by Kalev Lember's avatar Kalev Lember
Browse files

Release version 3.27.92

parent b3bb6db2
Version 3.27.92
~~~~~~~~~~~~~~~
Released: 2018-03-05
This is an unstable release in the 3.27 development series, marking the end of
the development cycle. Next release will be 3.28.0!
* Removal of global plugin cache, simplifying gnome-software internals
* Software Repositories dialog got another batch of improvements and UI
changes
* GNOME Shell Extensions repository and fwupd repositories are now shown in
the Software Repositories dialog
* Shell extensions handling through PackageKit was improved, fixing a long
standing bug where we were unable to remove shell extension packages
* Category page rewrite that landed earlier this cycle went through UI review
and got a number of fixes
* Package version comparison in the updates dialog was fixed and should no
longer incorrectly show updates as downgrades
* Distro upgrade notifications are now rate limited to once per week
* Install buttons in codec install view that got lost in the 3.22 cycle are
now back
* Various paper cuts with distro upgrades were fixed
* Various fixes to installing apps from yum repos that have enabled=0
enabled_metadata=1
* Various other correctness and warning fixes
* Distros: Minimum supported fwupd version is now 1.0.3
* Distros: We've released PackageKit 1.1.9 that has string changes to match
gnome-software 3.28
This release also updates translations.
Version 3.27.90
~~~~~~~~~~~~~~~
Released: 2018-02-14
......
......@@ -8,8 +8,8 @@ Add any user visible changes into data/appdata/org.gnome.Software.appdata.xml.in
Generate NEWS file:
appstream-util appdata-to-news data/appdata/org.gnome.Software.appdata.xml.in > NEWS
git commit -a -m "Release version 3.27.91"
git tag -s 3.27.91 -m "==== Version 3.27.91 ===="
git commit -a -m "Release version 3.27.92"
git tag -s 3.27.92 -m "==== Version 3.27.92 ===="
<enter password>
ninja-build dist
......
......@@ -46,6 +46,30 @@
Validate with `appstream-util validate *.appdata.xml`
-->
<releases>
<release date="2018-03-05" version="3.27.92">
<description>
<p>
This is an unstable release in the 3.27 development series,
marking the end of the development cycle. Next release will be 3.28.0!
</p>
<ul>
<li>Removal of global plugin cache, simplifying gnome-software internals</li>
<li>Software Repositories dialog got another batch of improvements and UI changes</li>
<li>GNOME Shell Extensions repository and fwupd repositories are now shown in the Software Repositories dialog</li>
<li>Shell extensions handling through PackageKit was improved, fixing a long standing bug where we were unable to remove shell extension packages</li>
<li>Category page rewrite that landed earlier this cycle went through UI review and got a number of fixes</li>
<li>Package version comparison in the updates dialog was fixed and should no longer incorrectly show updates as downgrades</li>
<li>Distro upgrade notifications are now rate limited to once per week</li>
<li>Install buttons in codec install view that got lost in the 3.22 cycle are now back</li>
<li>Various paper cuts with distro upgrades were fixed</li>
<li>Various fixes to installing apps from yum repos that have enabled=0 enabled_metadata=1</li>
<li>Various other correctness and warning fixes</li>
<li>Distros: Minimum supported fwupd version is now 1.0.3</li>
<li>Distros: We've released PackageKit 1.1.9 that has string changes to match gnome-software 3.28</li>
</ul>
<p>This release also updates translations.</p>
</description>
</release>
<release date="2018-02-14" version="3.27.90">
<description>
<p>
......
project('gnome-software', 'c',
version : '3.27.91',
version : '3.27.92',
license : 'GPL-2.0+',
default_options : ['warning_level=1', 'c_std=c99'],
meson_version : '>=0.37.0'
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment