libxmlb: Set the branch from debian to debian/0.1.8-1

Try to fix "gbp:error: upstream/0.1.8 is not a valid treeish".
1 job for add-libxmlb in 19 seconds (queued for 3 seconds)
Status Job ID Name Coverage
  Test
passed #144794
librem5
build-native

00:00:19