1. 30 Sep, 2020 3 commits
  2. 25 Sep, 2020 4 commits
  3. 21 Sep, 2020 2 commits
  4. 14 Sep, 2020 3 commits
  5. 31 Aug, 2020 4 commits
  6. 05 Aug, 2020 1 commit
  7. 28 Jul, 2020 6 commits
  8. 20 Jul, 2020 1 commit
  9. 07 Jul, 2020 1 commit
  10. 01 Jul, 2020 1 commit
  11. 23 Jun, 2020 1 commit
  12. 22 Jun, 2020 1 commit
    • Martin Kepplinger's avatar
      remove usr/bin/power_key.py · 73895838
      Martin Kepplinger authored
      The /usr/bin/power_key.py script basically does 2 things:
      
      * set a devfreq governor once (and handle frequencies but only on old kernels)
      * shut down the system when the power button is being pressed for ca. 2 seconds
      
      The first task is to be replaced via a simple udev rule. The second one
      is being tracked by Librem5/OS-issues#146
      
      
      and will be replaced by a GUI anyways.
      
      This solves problems with the power_key script:
      * it is not syncronised with the display system.
      * it is a nightmare to maintain and keep working
      
      In my tests, the long-press shutdown mechanism didn't work anymore, but if
      it does for you, this will remove it (temporarily, see the above issue).
      Signed-off-by: Martin Kepplinger's avatarMartin Kepplinger <martin.kepplinger@puri.sm>
      73895838
  13. 09 Jun, 2020 6 commits
  14. 23 Apr, 2020 2 commits
  15. 22 Apr, 2020 1 commit
  16. 06 Apr, 2020 1 commit
  17. 05 Apr, 2020 1 commit
  18. 03 Apr, 2020 1 commit
    • Martin Kepplinger's avatar
      power_key.py: make compatible with 5.6 and later and the devkit · 71f71c1c
      Martin Kepplinger authored
      devfreq is being handled differently on our kernels. With 5.6+ frequency
      is switched automatically by the kernel for devfreq, when the powersave
      governor is set. So in that case we only to that (done by udev in the future).
      
      This also makes devfreq settings compatible with the devkit again because
      it reads the minimum frequency which is different than on the phone,
      from sysfs.
      
      Also, we particularly handle 5.6-rc based kernel versions that
      include a broken devfreq implementation / setup. starting with version
      5.6.0 we need to increment the ABI version to 2.
      71f71c1c