Remove unnecessary dep to non-existent package

There is no libgio2.0-dev, but libgio-2.0.so is in libglib2.0-dev
2 jobs for librem5 in 2 minutes (queued for 3 seconds)