Commit 354bab4a authored by David Boddie's avatar David Boddie
Browse files

Merge branch 'patch-1' into 'master'

Update index.rst to remove direct DConf access

See merge request Librem5/developer.puri.sm!338
parents 8f61401c f84272b2
......@@ -8,7 +8,7 @@ Applications (apps) for the Librem 5 will typically be built using the
`GTK toolkit`_. In fact many of the apps available will have been ported from
existing apps which are part of the GNOME environment.
This guide aims to provide a brief overview of GTK 3 applications and the tools that can assist in their development. GTK 3.32 is the minimum version that applications on the Librem 5 are expected to use.
This guide aims to provide a brief overview of GTK 3 applications and the tools that can assist in their development. GTK 3.34 is the minimum version that applications on the Librem 5 are expected to use.
.. contents::
:local:
......
......@@ -33,9 +33,6 @@ Feature Flatpak Permissions
======================================= ================================================
Display a graphical user interface ``--socket=wayland``
Access the Internet using sockets ``--share=network``
Access settings (GNOME applications) ``--filesystem=~/.config/dconf:ro`` |br|
``--talk-name=ca.desrt.dconf`` |br|
``--env=DCONF_USER_CONFIG_DIR=.config/dconf``
Access Bluetooth devices ``--allow=bluetooth``
Read and write user's documents ``--xdg-documents``
Read and write user's downloads ``--xdg-download``
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment