Commit 582e6dcb authored by David Boddie's avatar David Boddie
Browse files

Merge branch 'update-gtk-gnome-versions' into 'master'

Update recommended GTK and GNOME versions to 3.34

See merge request Librem5/developer.puri.sm!342
parents 354bab4a d3f05d6d
......@@ -78,7 +78,7 @@ to install the runtime and SDK that the application depends on. These are the
same as those mentioned in :ref:`flatpak_setup_gnome` except that we need the
ones for the aarch64 architecture::
flatpak --user install flathub org.gnome.Platform/aarch64/3.32 org.gnome.Sdk/aarch64/3.32
flatpak --user install flathub org.gnome.Platform/aarch64/3.34 org.gnome.Sdk/aarch64/3.34
After installing these, build the application with ``flatpak-builder``:
......
......@@ -16,7 +16,7 @@ development system::
purism@pureos:~$ sudo apt-get install flatpak flatpak-builder
purism@pureos:~$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
purism@pureos:~$ flatpak install flathub org.gnome.Platform//3.32
purism@pureos:~$ flatpak install flathub org.gnome.Platform//3.34
You will also need to install a version of the `qemu`_ emulator that can be
used to assist with cross-compilation. This is described in
......
......@@ -8,7 +8,7 @@ This guide aims to show developers and designers how to use the components provi
.. contents::
:local:
This guide assumes that you are familiar with the basics of GTK application development. It also assumes you are using GTK 3.32 or newer and libhandy 0.0.10 or newer as these versions have improved support for adaptive apps over previous versions.
This guide assumes that you are familiar with the basics of GTK application development. It also assumes you are using GTK 3.34 or newer and libhandy 0.0.10 or newer as these versions have improved support for adaptive apps over previous versions.
Introduction
------------
......
{
"app-id": "com.example.some_example",
"runtime": "org.gnome.Platform",
"runtime-version": "3.32",
"runtime-version": "3.34",
"sdk": "org.gnome.Sdk",
"command": "my-program",
"finish-args": [
......
......@@ -85,7 +85,7 @@ to install the runtime and SDK that the application depends on. These are the
same as those mentioned in :ref:`flatpak_setup_gnome` except that we need the
ones for the aarch64 architecture::
flatpak --user install flathub org.gnome.Platform/aarch64/3.32 org.gnome.Sdk/aarch64/3.32
flatpak --user install flathub org.gnome.Platform/aarch64/3.34 org.gnome.Sdk/aarch64/3.34
After installing these, build the application with ``flatpak-builder``:
......
......@@ -18,7 +18,7 @@ to install the runtime and SDK that the application depends on. These are the
same as those mentioned in :ref:`flatpak_setup_gnome` except that we need the
ones for the aarch64 architecture::
flatpak --user install flathub org.gnome.Platform/aarch64/3.32 org.gnome.Sdk/aarch64/3.32
flatpak --user install flathub org.gnome.Platform/aarch64/3.34 org.gnome.Sdk/aarch64/3.34
After installing these, build the application with ``flatpak-builder``. For
example, here is how to build the |app-name| application from the |app-dir|
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment