INSTALL.in 1.41 KB
Newer Older
1 2 3
Prerequisites
=============

Owen Taylor's avatar
Owen Taylor committed
4 5
GTK+ requires the following packages:

6 7
 - The GLib, Pango, GdkPixbuf, ATK and cairo libraries, available at
   the same location as GTK+. GTK+ @GTK_VERSION@ requires at least
8 9 10
   GLib @GLIB_REQUIRED_VERSION@, Pango @PANGO_REQUIRED_VERSION@,
   GdkPixbuf @GDK_PIXBUF_REQUIRED_VERSION@, ATK @ATK_REQUIRED_VERSION@
   and cairo @CAIRO_REQUIRED_VERSION@.
Owen Taylor's avatar
Owen Taylor committed
11

12 13 14
 - libepoxy, for cross-platform OpenGL support.
   It can be found here: https://github.com/anholt/libepoxy

15 16
 - Each GDK backend has its own backend-specific requirements. For
   the X11 backend, X11 R6 and XInput version 2 (as well as a number
17 18
   of other extensions) are required. The Wayland backend requires
   (obviously) the Wayland libraries.
19

20
 - gobject-introspection @INTROSPECTION_REQUIRED_VERSION@ or newer.
21

22 23 24
Simple install procedure
========================

25 26
  % tar xf gtk+-@GTK_VERSION@.tar.xz          # unpack the sources
  % cd gtk+-@GTK_VERSION@                     # change to the toplevel directory
27 28
  % ./configure                        # run the `configure' script
  % make                               # build GTK+
29
  [ Become root if necessary ]
30
  % make install                       # install GTK+
31

32 33
The Details
===========
34

35 36
Complete information about installing GTK+ and related libraries
can be found in the file:
37

Matthias Clasen's avatar
Matthias Clasen committed
38
 docs/reference/gtk/html/gtk-building.html
39

40
Or online at:
41

42
 http://library.gnome.org/devel/gtk/stable/gtk-building.html