1. 12 Jan, 2014 1 commit
  2. 23 Sep, 2013 1 commit
  3. 05 May, 2013 2 commits
  4. 17 Mar, 2013 1 commit
  5. 23 Oct, 2012 1 commit
  6. 17 Oct, 2012 1 commit
  7. 01 May, 2012 2 commits
    • Benjamin Otte's avatar
      versionmacros: min-require the current stable version · 12846d82
      Benjamin Otte authored
      .. instead of the previous stable version.
      
      This ensures that if we use GDK_DEPRECATED_IN_3_6, it will actually emit
      a warning in GTK 3.5, and not wait with that until GTK 3.7. This is
      particularly useful for stuff that gets deprecated right now. This code
      should emit warnings right now, so we know what we're doing while
      deprecating.
      12846d82
    • Benjamin Otte's avatar
      docs: Fix copy/paste typo · 7bb19b85
      Benjamin Otte authored
      7bb19b85
  8. 18 Apr, 2012 1 commit
  9. 17 Apr, 2012 1 commit
  10. 27 Feb, 2012 2 commits
    • Matthias Clasen's avatar
      f6d8c8a7
    • Matthias Clasen's avatar
      Add versioned deprecation macros · e580c79a
      Matthias Clasen authored
      These macros follow the recent changes in GLibs deprecation
      setup. We now annotate deprecated functions with the version
      they were deprecated in, and you can define the macro
      GDK_VERSION_MIN_REQUIRED to cut off deprecation warnings for
      'recent' deprecations.
      
      At the same time, we introduce version annotations for new API
      and allow you to avoid 'recent' API additions by defining
      GDK_VERSION_MAX_ALLOWED.
      e580c79a