Commit 2a0436ca authored by Guido Gunther's avatar Guido Gunther

Use meta packages

A first step to reduce the image build scripts
parent ad932d5d
Pipeline #1057 passed with stage
in 15 seconds
# Packages to install on all boards
gui_packages="
libgl1-mesa-dri
libpam-systemd
libhandy-0.0-0
librem5-theme-default
libwlroots-examples
phosh
virtboard
weston
calls
epiphany-browser
evince
gnome-calendar
gnome-chess
gnome-contacts
gnome-control-center
gnome-maps
gnome-online-accounts
gnome-session
gnome-settings-daemon
gnome-terminal
gnome-tweaks
network-manager-gnome
xdg-desktop-portal-gtk
"
gui_dev_packages="
build-essential
libcap-dev
libdrm-dev
libegl1-mesa-dev
libgbm-dev
libgles2-mesa-dev
libinput-dev
libsystemd-dev
libwayland-dev
libxcb1-dev
libxcb-composite0-dev
libxcb-icccm4-dev
libxcb-image0-dev
libxcb-render0-dev
libxcb-xfixes0-dev
libxkbcommon-dev
meson
libgnome-desktop-3-dev
libgtk-3-dev
libpixman-1-dev
"
dev_packages="
alsa-utils
bash-completion
dconf-editor
device-tree-compiler
edid-decode
evtest
gdb
git
i2c-tools
kbd
lsof
net-tools
openssh-client
openssh-server
read-edid
screen
strace
systemd-coredump
u-boot-tools
unzip
vim-gtk3
wireless-tools
${gui_dev_packages}
"
wwan_packages="
libqmi-utils
modemmanager
libmbim-utils
usb-modeswitch
"
# Packages to install on all dev boards
packages="
ca-certificates
cloud-initramfs-growroot
dosfstools
flatpak
libnss-systemd
locales
lvm2
usbutils
${gui_packages}
${dev_packages}
${wwan_packages}
librem5-gnome
librem5-dev-tools
librem5-gnome-dev
"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment