Commit afb2845b authored by Guido Gunther's avatar Guido Gunther

build: Build depend on newer GTK

We need 3.24.8 at runtime to render system modal dialogs correctly.
Express this as a build time requirement to make people aware.

This breaks building on plain Debian Buster.
Signed-off-by: Guido Gunther's avatarGuido Günther <guido.gunther@puri.sm>
parent d7b18c1d
Pipeline #23953 passed with stages
in 5 minutes and 5 seconds
......@@ -91,7 +91,10 @@ phosh_deps = [
dependency('glib-2.0', version: '>=2.50.0'),
dependency('gnome-desktop-3.0', version: '>=3.26'),
dependency('gobject-2.0', version: '>=2.50.0'),
dependency('gtk+-3.0', version: '>=3.22'),
# We need gtk 3.24.10 to render e.g. modal dialogs correctly:
# https://source.puri.sm/Librem5/phosh/merge_requests/219
# Older versions lie 3.24.5 are sufficient for building
dependency('gtk+-3.0', version: '>=3.24.8'),
dependency('gtk+-wayland-3.0', version: '>=3.22'),
dependency('wayland-client', version: '>=1.14'),
dependency('libhandy-0.0', version: '>=0.0.1', fallback: ['libhandy', 'libhandy_dep']),
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment