build: Build depend on newer GTK

We need 3.24.8 at runtime to render system modal dialogs correctly.
Express this as a build time requirement to make people aware.

This breaks building on plain Debian Buster.

Signed-off-by: Guido Günther <guido.gunther@puri.sm>
5 jobs for gtk-dep in 5 minutes and 5 seconds
latest
Status Job ID Name Coverage
  Build
passed #96767
librem5
build:native

00:01:21

 
  Test
passed #96768
librem5
test:native

00:01:26

passed #96769
librem5
test:smoke:one-output

00:02:15

passed #96770
librem5
test:smoke:two-outputs

00:02:16

 
  Package
passed #96771
librem5
package:deb

00:01:27