Commit 399f9f4a authored by Eugen Rochko's avatar Eugen Rochko Committed by GitHub
Browse files

Update Goldfinger gem to 2.0 (#4286)

- No masking of HTTP::Error and OpenSSL::SSL::SSLError
- No longer accepts non-HTTPS WebFinger endpoints
parent f2390e28
......@@ -28,7 +28,7 @@ gem 'devise', '~> 4.2'
gem 'devise-two-factor', '~> 3.0'
gem 'doorkeeper', '~> 4.2'
gem 'fast_blank', '~> 1.0'
gem 'goldfinger', '~> 1.2'
gem 'goldfinger', '~> 2.0'
gem 'hiredis', '~> 0.6'
gem 'redis-namespace', '~> 1.5'
gem 'htmlentities', '~> 4.3'
......
......@@ -166,10 +166,11 @@ GEM
gemoji (3.0.0)
globalid (0.4.0)
activesupport (>= 4.2.0)
goldfinger (1.2.0)
addressable (~> 2.4)
http (~> 2.0)
nokogiri (~> 1.6)
goldfinger (2.0.0)
addressable (~> 2.5)
http (~> 2.2)
nokogiri (~> 1.8)
oj (~> 3.0)
hamlit (2.8.4)
temple (>= 0.8.0)
thor
......@@ -523,7 +524,7 @@ DEPENDENCIES
fast_blank (~> 1.0)
fuubar (~> 2.2)
gemoji (~> 3.0)
goldfinger (~> 1.2)
goldfinger (~> 2.0)
hamlit-rails (~> 0.2)
hiredis (~> 0.6)
htmlentities (~> 4.3)
......@@ -591,4 +592,4 @@ RUBY VERSION
ruby 2.4.1p111
BUNDLED WITH
1.15.1
1.15.2
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment