Commit 7294fd47 authored by David Seaward's avatar David Seaward
Browse files

Switch from strictyaml to ruamel.yaml, because strictyaml isn't available in Debian yet.


Signed-off-by: David Seaward's avatarDavid Seaward <david.seaward@puri.sm>
parent c5b33c7e
......@@ -7,8 +7,8 @@ name = "pypi"
click = ">=7.0, <8.0"
distro = ">=1.3.0, <2.0"
requests = ">=2.21.0, <3.0"
"ruamel.yaml" = ">=0.15.34, <1.0"
sh = ">=1.12.14, <2.0"
strictyaml = ">=1.0.6, <2.0"
PyGObject = ">=3.32.0, <4.0"
[dev-packages]
......
{
"_meta": {
"hash": {
"sha256": "5e39cba25b021be5e07e52768d38dafaa5a0d0d85f20b1dac1ea64fafeeb82ad"
"sha256": "d127c7a1986fe03e454ffe0659028b0a42827324934666ba2a2f0ac3e9f021d0"
},
"pipfile-spec": 6,
"requires": {},
......@@ -64,13 +64,6 @@
"index": "pypi",
"version": "==3.34.0"
},
"python-dateutil": {
"hashes": [
"sha256:73ebfe9dbf22e832286dafa60473e4cd239f8592f699aa5adaf10050e6e1823c",
"sha256:75bb3f31ea686f1197762692a9ee6a7550b59fc6ca3a1f4b5d7e32fb98e2da2a"
],
"version": "==2.8.1"
},
"requests": {
"hashes": [
"sha256:43999036bfa82904b6af1d99e4882b560e5e2c68e5c4b0aa03b655f3d7d73fee",
......@@ -84,6 +77,7 @@
"sha256:0962fd7999e064c4865f96fb1e23079075f4a2a14849bcdc5cdba53a24f9759b",
"sha256:099c644a778bf72ffa00524f78dd0b6476bca94a1da344130f4bf3381ce5b954"
],
"index": "pypi",
"version": "==0.16.10"
},
"ruamel.yaml.clib": {
......@@ -119,20 +113,6 @@
"index": "pypi",
"version": "==1.12.14"
},
"six": {
"hashes": [
"sha256:236bdbdce46e6e6a3d61a337c0f8b763ca1e8717c03b369e87a7ec7ce1319c0a",
"sha256:8f3cd2e254d8f793e7f3d6d9df77b92252b52637291d0f0da013c76ea2724b6c"
],
"version": "==1.14.0"
},
"strictyaml": {
"hashes": [
"sha256:dd687a32577e0b832619ce0552eac86d6afad5fa7b61ab041bb765881c6a1f36"
],
"index": "pypi",
"version": "==1.0.6"
},
"urllib3": {
"hashes": [
"sha256:2f3db8b19923a873b3e5256dc9c2dedfa883e33d87c690d9c7913e1f40673cdc",
......@@ -311,13 +291,6 @@
"index": "pypi",
"version": "==3.34.0"
},
"python-dateutil": {
"hashes": [
"sha256:73ebfe9dbf22e832286dafa60473e4cd239f8592f699aa5adaf10050e6e1823c",
"sha256:75bb3f31ea686f1197762692a9ee6a7550b59fc6ca3a1f4b5d7e32fb98e2da2a"
],
"version": "==2.8.1"
},
"readme-renderer": {
"hashes": [
"sha256:bb16f55b259f27f75f640acf5e00cf897845a8b3e4731b5c1a436e4b8529202f",
......@@ -345,6 +318,7 @@
"sha256:0962fd7999e064c4865f96fb1e23079075f4a2a14849bcdc5cdba53a24f9759b",
"sha256:099c644a778bf72ffa00524f78dd0b6476bca94a1da344130f4bf3381ce5b954"
],
"index": "pypi",
"version": "==0.16.10"
},
"ruamel.yaml.clib": {
......@@ -395,13 +369,6 @@
],
"version": "==1.14.0"
},
"strictyaml": {
"hashes": [
"sha256:dd687a32577e0b832619ce0552eac86d6afad5fa7b61ab041bb765881c6a1f36"
],
"index": "pypi",
"version": "==1.0.6"
},
"tqdm": {
"hashes": [
"sha256:0d8b5afb66e23d80433102e9bd8b5c8b65d34c2a2255b2de58d97bd2ea8170fd",
......
#!/usr/bin/env python3
# Copyright 2017-2020 Purism SPC
# SPDX-License-Identifier: AGPL-3.0-or-later
import pkg_resources
import strictyaml
import ruamel.yaml as yaml
default_yaml = pkg_resources.resource_string(
__name__, "../data/default.strict.yaml"
).decode("utf-8")
DEFAULT = strictyaml.load(default_yaml)
DEFAULT = yaml.safe_load(default_yaml)
[metadata]
name = ldh_client
version = 0.0.5
version = 0.0.6
description = Liberty CLI is a user-facing command-line client for interacting with Librem One or another Liberty Deckplan Host (LDH).
long_description = file: README.md
long_description_content_type = text/markdown; charset=UTF-8
......@@ -22,8 +22,8 @@ install_requires =
click >=7.0, <8.0
distro >=1.3.0, <2.0
requests >=2.21.0, <3.0
ruamel.yaml >=0.15.34, <1.0
sh >=1.12.14, <2.0
strictyaml >=1.0.6, <2.0
PyGObject >=3.32.0, <4.0
scripts = liberty.py
......
from setuptools import setup, find_packages
import setuptools
setup()
setuptools.setup()
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment