scripts: builddeb: only check if BUILD_LIBC_PKG is set

For linux-next-librem5 releases BUILD_LIBC_PKG doesn't even get set and
if trying to compare, we get:

./scripts/package/builddeb: 204: [: Illegal number:

so only test if it is set.

Signed-off-by: Martin Kepplinger <martin.kepplinger@puri.sm>
2 jobs for builddeb_libc_fix in 49 minutes and 32 seconds (queued for 1 second)