Commit f7185ea7 authored by Guido Gunther's avatar Guido Gunther

build: Specifify glib versions

This avoids deprecation warnings due to GTimeVal used in
libebook-contacts.h

See https://tecnocode.co.uk/2019/08/24/gtimeval-deprecation-in-glib-2-61-2/

It's already fixed in newer eds so we can drop
this once we move to a newer stack.
parent 09cbdf41
......@@ -58,6 +58,11 @@ config_data.set_quoted('PACKAGE_URL', calls_homepage)
config_data.set_quoted('PACKAGE_VERSION', calls_version)
config_data.set('PACKAGE_URL_RAW', calls_homepage)
add_project_arguments([
'-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_58',
'-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_60',
], language: 'c')
subdir('po')
subdir('src')
subdir('plugins')
......
......@@ -28,7 +28,7 @@ gnome = import('gnome')
src_include = include_directories('.')
calls_includes = [ top_include, src_include ]
calls_deps = [ dependency('gobject-2.0'),
calls_deps = [ dependency('gobject-2.0', version: '>= 2.58'),
dependency('gtk+-3.0'),
dependency('libhandy-0.0', version: '>= 0.0.12'),
dependency('gsound'),
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment