Commit 6c5584b5 authored by Michael Tokarev's avatar Michael Tokarev
Browse files

add Breaks: binfmt-support (<<2.1.7) so that --fix-binary works; also fix...

add Breaks: binfmt-support (<<2.1.7) so that --fix-binary works; also fix qemu-user-static description
parent a8c78937
...@@ -359,7 +359,8 @@ Architecture: amd64 arm arm64 armel armhf i386 ia64 mips mipsel mips64 mips64el ...@@ -359,7 +359,8 @@ Architecture: amd64 arm arm64 armel armhf i386 ia64 mips mipsel mips64 mips64el
Built-Using: ${built-using} Built-Using: ${built-using}
Multi-Arch: foreign Multi-Arch: foreign
Depends: ${shlibs:Depends}, ${misc:Depends} Depends: ${shlibs:Depends}, ${misc:Depends}
Recommends: binfmt-support (>= 2.1.7) Recommends: binfmt-support
Breaks: binfmt-support (<< 2.1.7~)
Provides: qemu-user-binfmt Provides: qemu-user-binfmt
Conflicts: qemu-user-binfmt Conflicts: qemu-user-binfmt
Suggests: sudo Suggests: sudo
...@@ -373,14 +374,15 @@ Description: QEMU user mode emulation binaries (static version) ...@@ -373,14 +374,15 @@ Description: QEMU user mode emulation binaries (static version)
statically. In this mode QEMU can launch Linux processes compiled for statically. In this mode QEMU can launch Linux processes compiled for
one CPU on another CPU. one CPU on another CPU.
. .
If binfmt-support package is installed, qemu-user-static package will qemu-user-static package will register binary formats which the provided
register binary formats which the provided emulators can handle, so emulators can handle, so that it will be possible to run foreign binaries
that it will be possible to run foreign binaries directly. directly.
Package: qemu-user-binfmt Package: qemu-user-binfmt
Architecture: amd64 arm arm64 armel armhf i386 ia64 mips mipsel mips64 mips64el powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32 Architecture: amd64 arm arm64 armel armhf i386 ia64 mips mipsel mips64 mips64el powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32
Multi-Arch: foreign Multi-Arch: foreign
Depends: ${misc:Depends}, qemu-user (= ${binary:Version}), binfmt-support Depends: ${misc:Depends}, qemu-user (= ${binary:Version}), binfmt-support
Breaks: binfmt-support (<< 2.1.7~)
Conflicts: qemu-user-static Conflicts: qemu-user-static
Description: QEMU user mode binfmt registration for qemu-user Description: QEMU user mode binfmt registration for qemu-user
QEMU is a fast processor emulator: currently the package supports QEMU is a fast processor emulator: currently the package supports
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment