Commit aafe1c8c authored by Michael Tokarev's avatar Michael Tokarev
Browse files

enable virtio gpu (virglrenderer) and opengl support (#813658)

Add build-depends on libdrm-dev, libgbm-dev, libepoxy-dev, libx11-dev
(for opengl) and and libvirglrenderer-dev.

libegl1-mesa-dev build-dependency is because libepoxy-dev includes
header from it but does not depend on it
parent 5ef28150
......@@ -36,6 +36,7 @@ qemu (1:2.8+dfsg-1) UNRELEASED; urgency=medium
* install trace-events-all in qemu-system-common
* do not install qemu-tech.html (not provided by upstream anymore)
* switch from sdl1 to gtk3 (Closes: #839695)
* enable virtio gpu (virglrenderer) and opengl support (Closes: #813658)
-- Michael Tokarev <mjt@tls.msk.ru> Fri, 23 Dec 2016 14:54:28 +0300
......
......@@ -44,6 +44,13 @@ Build-Depends: debhelper (>= 9),
# gtk display (see also sdl display)
# --enable-gtk --with-gtkabi=3.0 --enable-vte
libgtk-3-dev, libvte-2.91-dev,
# opengl for sdl2 and gtk3
# --enable-opengl
# libegl1-mesa-dev is here b/c libepoxy-dev includes header from it
libdrm-dev, libgbm-dev, libepoxy-dev, libx11-dev, libegl1-mesa-dev,
# virglrenderer: virtio gpu support for guest
# --enable-virglrenderer
libvirglrenderer-dev,
# libiscsi is debian-only since ubuntu/libiscsi is in universe
:debian:# --enable-libiscsi
:debian: libiscsi-dev (>> 1.9.0~),
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment