Commit af0fa69d authored by Michael Tokarev's avatar Michael Tokarev
Browse files

move seabios and ipxe from Suggests to Recommends

parent 611a04d4
......@@ -3,16 +3,14 @@ qemu (2.1+dfsg-10) UNRELEASED; urgency=medium
* make (debian-specific) x86 data path (with seabios and ipxe
in it) non-x86-specific, since other arches use firmware
files too (Closes: #772127)
* add seabios to Suggests to qemu-system-misc, qemu-system-mips,
* add seabios to Recommends to qemu-system-misc, qemu-system-mips,
qemu-system-ppc and qemu-system-sparc packages, because these
packages contains emulators using vgabios which is part of
seabios package (#772127). Suggests only for now, may promote
to Recommends or even Depends in the future.
* add ipxe-qemu to Suggests to qemu-system-misc, qemu-system-arm,
seabios package (#772127).
* add ipxe-qemu to Recommends to qemu-system-misc, qemu-system-arm,
qemu-system-mips, qemu-system-ppc, qemu-system-sparc packages,
because these packages contains emulators using network boot
roms (#772127), in a similar way. Also suggests for now, may
be promoted to Recommends (but not Depends).
roms (#772127), in a similar way.
-- Michael Tokarev <mjt@tls.msk.ru> Fri, 05 Dec 2014 14:34:02 +0300
......
......@@ -200,11 +200,11 @@ Package: qemu-system-misc
Architecture: amd64 arm arm64 armel armhf hppa i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32
Multi-Arch: foreign
Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7~)
Recommends: qemu-utils
Suggests: samba, vde2,
Recommends: qemu-utils,
# alpha uses vgabios
# alpha m68k sh4 uses bootroms
seabios, ipxe-qemu
Suggests: samba, vde2
Provides: ${sysprovides:misc}
Breaks: qemu-system (<< 1.3.0+dfsg-5)
Replaces: qemu-system (<< 1.3.0+dfsg-5)
......@@ -228,10 +228,10 @@ Package: qemu-system-arm
Architecture: amd64 arm arm64 armel armhf hppa i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32
Multi-Arch: foreign
Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7~)
Recommends: qemu-utils
Suggests: samba, vde2,
Recommends: qemu-utils,
# aarch64 arm uses bootroms
ipxe-qemu
Suggests: samba, vde2
Provides: ${sysprovides:arm}
Breaks: qemu-system (<< 1.3.0+dfsg-5),
:ubuntu: qemu-common (<< 1.3.0+dfsg-5),
......@@ -260,10 +260,10 @@ Package: qemu-system-mips
Architecture: amd64 arm arm64 armel armhf hppa i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32
Multi-Arch: foreign
Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7~)
Recommends: qemu-utils
Suggests: samba, vde2,
Recommends: qemu-utils,
# all mips targets uses vgabios and bootroms
seabios, ipxe-qemu
Suggests: samba, vde2
Provides: ${sysprovides:mips}
Breaks: qemu-system (<< 1.3.0+dfsg-5)
Replaces: qemu-system (<< 1.3.0+dfsg-5)
......@@ -288,10 +288,10 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7
# ubuntu can't Depend on openbios-ppc and openhackware as they're in universe
:debian: openbios-ppc (>= 1.1+svn1229), openhackware
Suggests: samba, vde2,
:ubuntu: openbios-ppc (>= 1.1+svn1229), openhackware
Recommends: qemu-utils,
# ppc targets use vgabios-stdvga and bootroms
seabios, ipxe-qemu
:ubuntu: openbios-ppc (>= 1.1+svn1229), openhackware
Recommends: qemu-utils
Provides: ${sysprovides:ppc}
Breaks: qemu-system (<< 1.3.0+dfsg-5),
:ubuntu: qemu-common (<< 1.3.0+dfsg-5),
......@@ -320,10 +320,10 @@ Multi-Arch: foreign
Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7~),
# ubuntu/openbios-sparc is in universe
:debian: openbios-sparc (>= 1.1+svn1229)
Recommends: qemu-utils
Suggests: samba, vde2,
Recommends: qemu-utils,
# sparc64 uses vgabios-stdvga and bootroms
seabios, ipxe-qemu
Suggests: samba, vde2
Provides: ${sysprovides:sparc}
Breaks:
qemu-system (<< 1.3.0+dfsg-5),
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment