Commit e18aca63 authored by Guido Gunther's avatar Guido Gunther
Browse files

Merge branch 'update-submodule' into 'master'

Update submodule

See merge request Librem5/librem5-ci!1
parents a0b3dc5c 6bc38fb7
...@@ -5,7 +5,7 @@ job: ...@@ -5,7 +5,7 @@ job:
- echo "man-db man-db/auto-update boolean false" | debconf-set-selections - echo "man-db man-db/auto-update boolean false" | debconf-set-selections
- export DEBIAN_FRONTEND=noninteractive - export DEBIAN_FRONTEND=noninteractive
- apt-get -y update - apt-get -y update
- apt-get -y install python3-yaml - apt-get -y install python3-yaml make
script: script:
- python3 -c 'import yaml; import pprint; c = yaml.load(open("librem5-pipeline-definitions.yml")); pprint.pprint(c)' - make check
check:
python3 -c 'import yaml; import pprint; c = yaml.load(open("librem5-pipeline-definitions.yml")); pprint.pprint(c)'
...@@ -5,6 +5,7 @@ variables: ...@@ -5,6 +5,7 @@ variables:
L5_ADD_SCRATCH_CI: 'true' L5_ADD_SCRATCH_CI: 'true'
L5_WORKING_DIR: $CI_PROJECT_DIR/debian/output L5_WORKING_DIR: $CI_PROJECT_DIR/debian/output
L5_LINTIAN_OPTS: --suppress-tags bad-distribution-in-changes-file L5_LINTIAN_OPTS: --suppress-tags bad-distribution-in-changes-file
L5_GIT_SUBMODULE_UPDATE: 'true'
.l5-build-debian-package: .l5-build-debian-package:
image: ${L5_DOCKER_IMAGE} image: ${L5_DOCKER_IMAGE}
...@@ -15,12 +16,13 @@ variables: ...@@ -15,12 +16,13 @@ variables:
- echo "man-db man-db/auto-update boolean false" | debconf-set-selections - echo "man-db man-db/auto-update boolean false" | debconf-set-selections
- export DEBIAN_FRONTEND=noninteractive - export DEBIAN_FRONTEND=noninteractive
- apt-get -y update - apt-get -y update
- '[ "$L5_ADD_SCRATCH_CI" != "true" ] || apt-get -y install build-essential wget ca-certificates gnupg' - '[ "$L5_ADD_SCRATCH_CI" != "true" ] || apt-get -y install build-essential wget ca-certificates gnupg git'
- '[ "$L5_ADD_SCRATCH_CI" != "true" ] || echo "deb http://ci.puri.sm/ scratch librem5" > /etc/apt/sources.list.d/ci.list' - '[ "$L5_ADD_SCRATCH_CI" != "true" ] || echo "deb http://ci.puri.sm/ scratch librem5" > /etc/apt/sources.list.d/ci.list'
- '[ "$L5_ADD_SCRATCH_CI" != "true" ] || wget -O- https://ci.puri.sm/ci-repo.key | apt-key add -' - '[ "$L5_ADD_SCRATCH_CI" != "true" ] || wget -O- https://ci.puri.sm/ci-repo.key | apt-key add -'
- apt-get -y update - apt-get -y update
- apt-get -y build-dep . - apt-get -y build-dep .
script: script:
- '[ "$L5_GIT_SUBMODULE_UPDATE" != "true" ] || git submodule update --recursive'
- dpkg-buildpackage -b -uc -us - dpkg-buildpackage -b -uc -us
- rm -rf "${L5_WORKING_DIR}"; mkdir -p "${L5_WORKING_DIR}" - rm -rf "${L5_WORKING_DIR}"; mkdir -p "${L5_WORKING_DIR}"
- cp -l ../*.deb ../*.changes ../*.buildinfo "${L5_WORKING_DIR}/" - cp -l ../*.deb ../*.changes ../*.buildinfo "${L5_WORKING_DIR}/"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment