PolkitAuthAgent: fix build with Polkit >= 0.114

Polkit 0.114 introduced bunch of predefined g_autoptr cleanups, which
leads to compilation failure due to duplicate cleanup definition for
PolkitSubject. Note that even the latest polkit doesn't have a cleanup
for PolkitAgentListener defined, so it's left there unguarded.
5 jobs for polkit-compatibility in 5 minutes and 43 seconds (queued for 1 second)
latest
Status Job ID Name Coverage
  Build
passed #78035
librem5
build:native

00:01:28

 
  Test
passed #78036
librem5
test:native

00:01:23

passed #78037
librem5
test:smoke:one-output

00:02:32

passed #78038
librem5
test:smoke:two-outputs

00:02:11

 
  Package
passed #78039
librem5
package:deb

00:01:42