d/rules: Depend on phoc >= 0.4.0

While we can run with older versions this makes sure people
pull in a recent enough version for all the feaures.

Signed-off-by: Guido Günther <guido.gunther@puri.sm>
15 jobs for v0.4.0 in 45 minutes and 36 seconds (queued for 1 second)
latest
Status Job ID Name Coverage
  Build
passed #278754
librem5
build:native-alpinelinux-edge

00:04:33

passed #278753
librem5
build:native-debian-bullseye

00:07:21

passed #278752
librem5
build:native-debian-buster

00:06:59

 
  Test+Docs
passed #278757
librem5
build-gtkdoc

00:03:54

passed #278758
librem5
check-po

00:00:47

passed #278760
librem5
test:smoke:one-output

00:03:26

passed #278761
librem5
test:smoke:two-outputs

00:03:01

passed #278759
librem5
unit-test:native-alpinelinux-edge

00:02:29

passed #278756
librem5
unit-test:native-debian-bullseye

00:05:16

passed #278755
librem5
unit-test:native-debian-buster

00:05:18

14.4%
 
  Package
passed #278762
librem5
package:deb-debian-buster

00:04:44

passed #278763
librem5:arm64
package:deb-debian-buster:arm64

00:10:08

passed #278764
librem5
package:deb-pureos-amber

00:05:07

 
  Test Package
passed #278765
librem5
autopkgtest-debian-buster-package

00:01:13

passed #278766
librem5
lintian-debian-buster-package

00:00:45