Commit 4b4c3348 authored by Guido Gunther's avatar Guido Gunther
Browse files

Check for dependencies

parent 8981216d
......@@ -13,7 +13,7 @@ Requirements
* ModemManager with ussd support (current git)
* mobile-broadband-provider-info with top-up support (current git)
* GTK+ >= 3.0.0, Debian package: libgtk+-3-0
* PyGI >= 2.28.3, Debian package: python-gobject
* PyGObject >= 2.28.3, Debian package: python-gobject
* DBus Python Bindings >= 0.83, Debian package: python-dbus
Project Page
......
......@@ -7,6 +7,16 @@ AM_INIT_AUTOMAKE([-Wno-portability])
IT_PROG_INTLTOOL([0.35.0])
GLIB_REQUIRED=2.25.6
GTK_REQUIRED=3.0.0
PYGOBJECT_REQUIRED=2.28.3
DBUS_PYTHON_REQUIRED=0.83
PKG_CHECK_MODULES(PPM, [glib-2.0 >= $GLIB_REQUIRED
gtk+-3.0 >= $GTK_REQUIRED
pygobject-2.0 >= $PYGOBJECT_REQUIRED
dbus-python >= $DBUS_PYTHON_REQUIRED])
GETTEXT_PACKAGE=prepaid-manager-applet
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package])
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment