Commit 51491bc5 authored by Guido Gunther's avatar Guido Gunther
Browse files

Switch to Debian bullseye and use prefefined pipeline

parent ac500329
include: include:
- 'https://source.puri.sm/Librem5/librem5-ci/raw/master/librem5-pipeline-definitions.yml' - 'https://source.puri.sm/Librem5/librem5-ci/raw/master/librem5-pipeline-definitions.yml'
variables:
L5_DOCKER_IMAGE: "debian:bullseye"
L5_ADD_SCRATCH_CI: "false"
stages: stages:
- package - package
- test-package - test-package
package:deb-debian-buster: package:deb-debian-bullseye:
extends: .l5-build-debian-package extends: .l5-build-debian-package
package:deb-debian-buster:arm64: package:deb-debian-bullseye:arm64:
tags: tags:
- librem5:arm64 - librem5:arm64
extends: .l5-build-debian-package extends: .l5-build-debian-package
package:check-tarball: autopkgtest-debian-bullseye-package:
stage: package
tags:
- librem5
image: debian:bullseye
before_script:
- apt update
- apt-get -y install build-essential git-buildpackage
- "rm -f ../*.orig.*"
script:
- gbp export-orig
- "md5sum ../*.orig.*"
- dpkg-buildpackage -uc -us -S -d -nc
autopkgtest-debian-buster-package:
dependencies: dependencies:
- package:deb-debian-buster - package:deb-debian-bullseye
extends: .l5-autopkgtest-debian-package extends: .l5-autopkgtest-debian-package
lintian-debian-buster-package: lintian-debian-bullseye-package:
dependencies: dependencies:
- package:deb-debian-buster - package:deb-debian-bullseye
extends: .l5-lintian-debian-package extends: .l5-lintian-debian-package
check-tarball:
extends: .l5-check-tarball
only:
changes:
- "debian/changelog"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment