• Michal Simek's avatar
    ARM: zynq: Fix building SPL without FPGA support · 0b680206
    Michal Simek authored
    When CONFIG_FPGA is defined but CONFIG_SPL_FPGA is not, the build fails:
    board.c: In function 'board_init':
    board.c:41:3: error: 'fpga' undeclared (first use in this function)
       fpga = fpga010;
    
    Fix this by expanding the "#if.." around this block to match the other
    FPGA checks and don't compile this block when buildign for SPL without
    FPGA support.
    
    Tested a bootloader that had CONFIG_FPGA defined without CONFIG_SPL_FPGA,
    this now compiles without errors and loading FPGA from u-boot works.
    Signed-off-by: default avatarMike Looijmans <mike.looijmans@topic.nl>
    Signed-off-by: default avatarMichal Simek <michal.simek@xilinx.com>
    0b680206
Name
Last commit
Last update
Licenses Loading commit data...
api Loading commit data...
arch Loading commit data...
board Loading commit data...
common Loading commit data...
disk Loading commit data...
doc Loading commit data...
drivers Loading commit data...
dts Loading commit data...
examples Loading commit data...
fs Loading commit data...
include Loading commit data...
lib Loading commit data...
nand_spl Loading commit data...
net Loading commit data...
post Loading commit data...
scripts Loading commit data...
spl Loading commit data...
test Loading commit data...
tools Loading commit data...
.checkpatch.conf Loading commit data...
.gitignore Loading commit data...
CREDITS Loading commit data...
Kbuild Loading commit data...
MAKEALL Loading commit data...
Makefile Loading commit data...
README Loading commit data...
boards.cfg Loading commit data...
config.mk Loading commit data...
mkconfig Loading commit data...
snapshot.commit Loading commit data...