Commit ba22f893 authored by Evangelos Ribeiro Tzaras's avatar Evangelos Ribeiro Tzaras
Browse files

d/rules: Use xvfb-run for the test suite

because the validation of .ui files using gtk-builder-tool
might fail otherwise.
parent 6bc6faa1
......@@ -25,6 +25,8 @@ Build-Depends:
libsoup2.4-dev,
libsqlite3-dev,
meson,
xauth,
xvfb,
Standards-Version: 4.5.0
Homepage: https://source.puri.sm/Librem5/chatty
Vcs-Browser: https://salsa.debian.org/DebianOnMobile-team/chatty
......
......@@ -14,3 +14,8 @@ override_dh_installman:
help2man --no-info --name "XMPP and SMS messaging" --section=1 \
debian/chatty/usr/bin/chatty > \
debian/chatty/usr/share/man/man1/chatty.1
# otherwise the tests running gtk-builder-tool to validate
# .ui files might fail
override_dh_auto_test:
xvfb-run dh_auto_test
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment